Sync broken for folder with Unicode U+200F Right-to-left mark

Contributor

I had a user contact me about folders missing on their laptop. We checked their office PC and they were there -- within OneDrive connected to 365. However, the missing items had the blue 'syncing' arrows on them. The icon on the taskbar reported however that sync was complete with no issues.

 

I created a new folder and moved the items into, and they sync'd fine.

 

I later realised that the original folder appeared in DIR command output as "Dave ?Virgo".  Inspection via explorer and a hex editor showed that it was Unicode character U+200F "Right-to-left mark" being displayed as the question mark. (The character wasn't visible in explorer of course.)

 

So seems like OneDrive has problems with folders with odd characters. Anyone else seen this? Or is it documented even?

 

Such a pity that the sync showed as complete with no issues when there was this handful of child folder and files that had been ignored. The "Choose folders" didn't even show the child items -- so totally ignored...

3 Replies

Have you tried Microsoft Support and Recovery Assistant for Office 365?

It is available from http://diagnostics.outlook.com.

Run it and choose "I’m having a problem with OneDrive for Business".

I hadn't realised that feature was there. I fixed the problem already, but I will try this the next time I have problem.

Thanks

Alan

How did you fix the problem? I'm having a similar issue with syncing sharepoint folders to onedrive and getting question marks instead of some characters.

- Iyad