SOLVED

Request-SPOPersonalSite does not seem to work as desired (RESOLVED!)

%3CLINGO-SUB%20id%3D%22lingo-sub-88925%22%20slang%3D%22en-US%22%3ERequest-SPOPersonalSite%20does%20not%20seem%20to%20work%20as%20desired%20(RESOLVED!)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-88925%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20testing%20the%20PowerShell%20provisioning%20of%20OneDrive%20sites%20with%20simple%20script%20but%20it%20does%20not%20appear%20to%20be%20working.%3C%2FP%3E%3CP%3E%3CEM%3E%24tenant%20%3D%20%22AAAAAA%22%3C%2FEM%3E%3C%2FP%3E%3CP%3E%3CEM%3EImport-Module%20Microsoft.Online.SharePoint.PowerShell%20-DisableNameChecking%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3EConnect-SPOService%20-Url%20https%3A%2F%2F%24tenant-admin.sharepoint.com%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3E%24emails%20%3D%20%22jbagadonuts%40AAAAAA.com%2Cbmeints%40AAAAAA.com%22%3C%2FEM%3E%3CBR%20%2F%3E%3CEM%3ERequest-SPOPersonalSite%20-UserEmails%20%24emails%20-NoWait%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20all%20the%20latest%20modules%2C%20I%20run%20the%20script%2C%20and%20nothing%20happens.%26nbsp%3B%20I've%20waited%2024%2B%20hours%20for%20the%20accounts%20to%20be%20provisioned%2C%20but%20in%20the%20admin%20panel%20when%20looking%20at%20users%2C%20it%20shows%20user's%20OneDrive%20not%20provisioned.%26nbsp%3B%20Anyone%20else%20see%20this%20behavior%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-88925%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOneDrive%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-101439%22%20slang%3D%22en-US%22%3ERe%3A%20Request-SPOPersonalSite%20does%20not%20seem%20to%20work%20as%20desired%20(SOLVED)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-101439%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20two%20additional%20points%3A%3C%2FP%3E%3CUL%3E%3CLI%3EIf%20the%20account%20is%20synced%20with%20AD%2C%20do%20not%20enable%20the%20option%20the%20user%20has%20to%20change%20his%20password%20at%20the%20next%20logon.%20The%26nbsp%3BRequest-SPOPersonalSite%20command%20has%20a%20timeout%20if%20the%20option%20is%20active.%3C%2FLI%3E%3CLI%3E%3CSPAN%3ERequest-SPOPersonalSite%3C%2FSPAN%3E%20is%20also%20not%20possible%20if%20the%20account%20is%20disabled%20or%20blocked.%26nbsp%3B%3C%2FLI%3E%3C%2FUL%3E%3CP%3ERegards%3C%2FP%3E%3CP%3ETobias%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-98098%22%20slang%3D%22en-US%22%3ERe%3A%20Request-SPOPersonalSite%20does%20not%20seem%20to%20work%20as%20desired%20(SOLVED)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-98098%22%20slang%3D%22en-US%22%3E%3CP%3EFound%20the%20solution%20after%20working%20with%20Microsoft%20Premier%20support.%26nbsp%3B%20There%20are%20two%20errors%20on%20this%20page%3A%20%3CA%20href%3D%22https%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fdn792367.aspx%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Ftechnet.microsoft.com%2Fen-us%2Flibrary%2Fdn792367.aspx%3C%2FA%3E%20(as%20of%208%2F21%2F2017).%26nbsp%3B%20It%20does%20not%20mention%3A%3C%2FP%3E%3CP%3E1.%26nbsp%3BIn%20addition%20to%20being%20an%20admin%20account%2C%26nbsp%3Bthe%20account%20doing%20the%20provisioning%20MUST%20be%20licensed%20for%20SharePoint%20Online.%3C%2FP%3E%3CP%3E2.%20The%20syntax%20of%20the%20PowerShell%20was%20incorrect%20in%20the%20original%20Microsoft%20page.%26nbsp%3B%20The%20emails%20should%20be%20EACH%20in%20quotes%2C%20separated%20by%20a%20comma%20(%22mail1%22%2C%22mail2%22)%3A%20so%20in%20original%20example%20it%20should%20read%3A%3C%2FP%3E%3CP%3E%3CI%3E%24emails%20%3D%20%22jbagadonuts%40AAAAAA.com%22%2C%22bmeints%40AAAAAA.com%22%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eafter%20running%20the%20PowerShell%2C%20SP%20Online%20timer%20job%20provisioned%20both%20in%20a%20few%20minutes.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

I'm testing the PowerShell provisioning of OneDrive sites with simple script but it does not appear to be working.

$tenant = "AAAAAA"

Import-Module Microsoft.Online.SharePoint.PowerShell -DisableNameChecking
Connect-SPOService -Url https://$tenant-admin.sharepoint.com
$emails = "jbagadonuts@AAAAAA.com,bmeints@AAAAAA.com"
Request-SPOPersonalSite -UserEmails $emails -NoWait

 

I have all the latest modules, I run the script, and nothing happens.  I've waited 24+ hours for the accounts to be provisioned, but in the admin panel when looking at users, it shows user's OneDrive not provisioned.  Anyone else see this behavior?

 

2 Replies
Highlighted
Best Response confirmed by Lou Mickley (Contributor)
Solution

Found the solution after working with Microsoft Premier support.  There are two errors on this page: https://technet.microsoft.com/en-us/library/dn792367.aspx (as of 8/21/2017).  It does not mention:

1. In addition to being an admin account, the account doing the provisioning MUST be licensed for SharePoint Online.

2. The syntax of the PowerShell was incorrect in the original Microsoft page.  The emails should be EACH in quotes, separated by a comma ("mail1","mail2"): so in original example it should read:

$emails = "jbagadonuts@AAAAAA.com","bmeints@AAAAAA.com"

 

after running the PowerShell, SP Online timer job provisioned both in a few minutes.

Highlighted

Just two additional points:

  • If the account is synced with AD, do not enable the option the user has to change his password at the next logon. The Request-SPOPersonalSite command has a timeout if the option is active.
  • Request-SPOPersonalSite is also not possible if the account is disabled or blocked. 

Regards

Tobias