OneDrive O365 Mobile App

Frequent Contributor

We have one O365 user when logged into the OneDrive mobile app they only have the Libraries section showing.


When I login I have Libraries, Recent Shared, Libraries and Me sections in the app.


I can see that under his account in the app settings it says Business where mine says the company name.


It looks like he may be logging into a different version of OneDrive, but how?


When he logs in via the web browser it all looks fine and he has the same O365 licensing options enabled as me.


This happens on both IOS and Android devices. On the same devices I can log into the app fine as explained above.

4 Replies
Only thing I could think of is this person has an Office 365 business account of some kind tied to his same e-mail alias and logging in for the Microsoft Account instead of the work account. I'd check the logged in account and go form there.
best response confirmed by blue-man (Frequent Contributor)

@Chris Webb I have resolved the issue.


I was able to replicate the issue and then resolve it. I am guessing OneDrive doesn't get provisioned properly under certain circumstances.


To replicate I needed to:


1. Create a test user

2. Sign into the OneDrive app without applying the SharePoint license to the user


I then could only see Libraries. Even when I applied the SharePoint license and un-installed and re-installed the app it still only displayed libraries after re-signing in again.


To resolve the issue I needed to (not too sure if all steps below are necessary, but this worked for me):


1. Uninstall the OneDrive mobile app

2. Removed the SharePoint  license from the user

3. Wait for a few minutes

4. Re-add the SharePoint license

5. Wait for a few minutes again

6. Sign into OneDrive web app and then sign-into the Sharepoint web app.

7. Install the OneDrive mobile app and then I signed into it again.

8. It now displays all of the correct options at the bottom.

Hmm, shouldn't be related to SharePoint, but OneDrive license. Almost sounds like the OneDrive didn't get provisioned all the way, but oyu said you went in as this user via web and OneDrive and files were there?

@Chris Webb There is no OneDrive license option to pick from. This user could not access OneDrive even via the web until we enabled the SharePoint license.


I tried the steps I detailed in my above earlier post, but it did not work. I tried removing the license uninstalling/installing, logging out all signed in session under the OneDrive tab in the user O365 user settings, then hours later all started working today for the person in question!


Not actually sure what fixed this for the user to be honest. Not to sure if it just took a while to sort the provisioning out or it was one of the steps I took. Really strange behaviour!