OneDrive for Business will not work on Mac

New Contributor



Since updating to MacOS Big Sur 11.6 my OneDrive for Business has stopped working! Even if I try and add it as a new Account there is zero response! Tried reloading from O365 as well as the Mac Store to no avail. 




14 Replies
Same here. I hope they fix it as fast as possible. I also found this:
Same here. I cannot use my business accounts anymore after updating to macOS 11.6.
Same for me as well. My personal account looks like it working just fine.
Have the same issue since macOS 11.6
Tried reseting OneDrive even performed a clean install, no results. It's impossible to sync business accounts anymore.
Microsoft put out a service alert about this today. OD284958 "Mac users may be unable to sign into or run multiple OneDrive for Business accounts on a single device". They're working with Apple to understand the issue and develop a solution.
Same here, only one OneDrive Sync can be set up at once
Same here. OneDrive "add account" button simply closes preferences window
Same here!
THANKS!!!! It magically works!



amazing, thank you so much for helping! :)

Yup, this works. Thanks!!
best response confirmed by SteveP2705 (New Contributor)



Looks like they have fixed it! An automatic Update came through yesterday and is all working now! Just Add and Account in Preferences/Account and add your Business Account! Working perfectly now!