OneDrive Enterprise Ring Issue

%3CLINGO-SUB%20id%3D%22lingo-sub-363618%22%20slang%3D%22en-US%22%3EOneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-363618%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EHi%20all%2C%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EIs%20anyone%20else%20trying%20to%20use%20the%20Enterprise%20Ring%20for%20OneDrive%3F%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EFor%20the%20life%20of%20me%20I%20cannot%20get%20our%20machines%20to%20respect%20the%20group%20policy%20%22GPOSetUpdateRing%22%20(we%20have%20it%20set%20to%200%20for%20Enterprise%20as%20per%20documentation.%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EThe%20OneDriveSetup.exe%20that%20we%20have%20deployed%20in%20SysWOW64%20is%2018.222.1104.0007%20(current%20enterprise%20release)%20however%20when%20a%20user%20logs%20in%20this%20is%20what%20happens%3A%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3E18.222.1104.0007%20is%20installed%20from%20SysWOW64%20as%20per%20usual%20(great!%20now%20just%20stop%20please!)%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3Ebut%20no!%20OneDrive%20Launches%2C%20detects%20an%20update%20and%20updates%20to%20the%20latest%20production%2019.012.0121.0011%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EAll%20of%20our%20other%20policies%20for%20OneDrive%20are%20working%20like%20auto%20config%20no%20personal%20accounts%20etc..%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EI%20also%20tried%20the%20legacy%20GP%20they%20said%20not%20use%20any%20more%20(in%20the%20documentation)%20%22EnableEnterpriseUpdate%22%20set%20to%201%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3EThat%20didn't%20work%20either.%3C%2FSPAN%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3CSPAN%3EAny%20thoughts%3F%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-363618%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOneDrive%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-400512%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-400512%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F100759%22%20target%3D%22_blank%22%3E%40Curtis%20Kutzan%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20also%20have%20this%20issue.%20Have%20you%20got%20it%20work%20now%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-444443%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-444443%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F100759%22%20target%3D%22_blank%22%3E%40Curtis%20Kutzan%3C%2FA%3EI'm%20seeing%20similar%20behaviour.%20GPO%20is%20applying%20fine%2C%20other%20setting%20work%20and%20the%20reg%20value%20you've%20referred%20to%20is%20applying%20but%20the%20client%20is%20still%20auto%20updating%20to%20the%20%22Production%22%20version%20instead%20of%20%22Enterprise%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20early%20on%20in%20testing%20this%20but%20already%20the%20details%20documented%20by%20Microsoft%20don't%20match%20what%20I%20see%20in%20the%20ADMX%20and%20this%20particular%20setting%20doesn't%20appear%20to%20be%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-689805%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-689805%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F100759%22%20target%3D%22_blank%22%3E%40Curtis%20Kutzan%3C%2FA%3EThe%20same%20issue%20also.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-691790%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-691790%22%20slang%3D%22en-US%22%3ENot%20sure%20if%20it%20is%20related%2C%20but%20I%20can't%20even%20configure%20OneDrive%20policies%20anymore%20with%20the%20latest%20admx%20files%20from%2019.086.0502.0006%3CBR%20%2F%3E%3CBR%20%2F%3EGPO%20Error%20when%20loading%20the%20administrative%20templates%3A%3CBR%20%2F%3E%3CBR%20%2F%3EResource%20'%24(string.GPOSetUpdateRing)'%20referenced%20in%20attribute%20displayName%20could%20not%20be%20found.%20File%20%5C%5C%3CNAME%20of%3D%22%22%20dc%3D%22%22%3E%5CSysVol%5Ccorp.acv.at%5CPolicies%5CPolicyDefinitions%5COneDrive.admx%2C%20line%2023%2C%20column%20235%3C%2FNAME%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699191%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699191%22%20slang%3D%22en-US%22%3EI%20also%20get%20this%20error%20now%20after%20applying%20the%20new%20ADMX%20template%2C%20i%20am%20assuming%20this%20has%20been%20superseded%20by%20another%20setting.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-715359%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-715359%22%20slang%3D%22en-US%22%3EAny%20idea%20on%20how%20to%20fix%20this%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-736297%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-736297%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1081%22%20target%3D%22_blank%22%3E%40Ivan%20Unger%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20had%20the%20same%20issue%20until%20I%20realized%20I%20placed%20both%20files%20(admx%20and%20adml)%20in%20the%20PolicyDefinitions%20folder.%20When%20I%20moved%20the%20adml%20file%20to%20the%20En-Us%20folder%20everything%20was%20fixed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-736349%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-736349%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20for%20me..%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-754278%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-754278%22%20slang%3D%22en-US%22%3EThanks%2C%20no%20idea%20how%20I%20missed%20this%2C%20afters%20years%20of%20working%20with%20admx%20files%20%3Ap%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-898327%22%20slang%3D%22en-US%22%3ERe%3A%20OneDrive%20Enterprise%20Ring%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-898327%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F370494%22%20target%3D%22_blank%22%3E%40Dimos_Panousis%3C%2FA%3E%26nbsp%3BThank%20you!%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Fhtml%2Fimages%2Femoticons%2Fstareyes_40x40.gif%22%20alt%3D%22%3Astareyes%3A%22%20title%3D%22%3Astareyes%3A%22%20%2F%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EJust%20followed%20the%20documentation%20blindly%20and%20didn't%20even%20think%20about%20that.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi all,

Is anyone else trying to use the Enterprise Ring for OneDrive?

For the life of me I cannot get our machines to respect the group policy "GPOSetUpdateRing" (we have it set to 0 for Enterprise as per documentation.

The OneDriveSetup.exe that we have deployed in SysWOW64 is 18.222.1104.0007 (current enterprise release) however when a user logs in this is what happens:

18.222.1104.0007 is installed from SysWOW64 as per usual (great! now just stop please!)
but no! OneDrive Launches, detects an update and updates to the latest production 19.012.0121.0011

All of our other policies for OneDrive are working like auto config no personal accounts etc..

I also tried the legacy GP they said not use any more (in the documentation) "EnableEnterpriseUpdate" set to 1
That didn't work either.

Any thoughts?

10 Replies
Highlighted

@Curtis Kutzan 

I also have this issue. Have you got it work now?

Highlighted

@Curtis KutzanI'm seeing similar behaviour. GPO is applying fine, other setting work and the reg value you've referred to is applying but the client is still auto updating to the "Production" version instead of "Enterprise".

 

I'm early on in testing this but already the details documented by Microsoft don't match what I see in the ADMX and this particular setting doesn't appear to be working.

Highlighted

@Curtis KutzanThe same issue also.

Highlighted
Not sure if it is related, but I can't even configure OneDrive policies anymore with the latest admx files from 19.086.0502.0006

GPO Error when loading the administrative templates:

Resource '$(string.GPOSetUpdateRing)' referenced in attribute displayName could not be found. File \\<name of dc>\SysVol\corp.acv.at\Policies\PolicyDefinitions\OneDrive.admx, line 23, column 235
Highlighted
I also get this error now after applying the new ADMX template, i am assuming this has been superseded by another setting.
Highlighted
Any idea on how to fix this?
Highlighted

@Ivan Unger 

 

I had the same issue until I realized I placed both files (admx and adml) in the PolicyDefinitions folder. When I moved the adml file to the En-Us folder everything was fixed.

Highlighted

Same for me.. 

Highlighted
Thanks, no idea how I missed this, afters years of working with admx files :p
Highlighted

@Dimos_Panousis Thank you! :stareyes:

 

Just followed the documentation blindly and didn't even think about that.