One Drive and iOS Files app connection issue

%3CLINGO-SUB%20id%3D%22lingo-sub-1336393%22%20slang%3D%22en-US%22%3EOne%20Drive%20and%20iOS%20Files%20app%20connection%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1336393%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%E2%80%99m%20using%20the%20iOS%20Files%20app%20to%20connect%20to%20One%20Drive.%26nbsp%3B%3CBR%20%2F%3ERecently%20I%20have%20experienced%20the%20following%20problem%20when%20trying%20to%20connect%20to%20One%20Drive.%3C%2FP%3E%3CP%3EFiles%20app%20displays%20the%20error%20message%2C%20Content%20Unavailable.%20The%20folder%20contents%20could%20not%20be%20displayed%20because%20of%20an%20unknown%20error%20-%20try%20again.%3C%2FP%3E%3CP%3EI%20have%20deleted%20the%20One%20Drive%20and%20iOS%20Files%20app%20and%20reinstalled%20and%20tried%20to%20connect%20again%20but%20the%20problem%20continues.%20I%20have%20logged%20an%20issue%20with%20One%20Drive%20but%20we%20seem%20to%20be%20going%20around%20in%20circles%20and%20the%20agent%20doesn%E2%80%99t%20get%20the%20issue%2C%20even%20after%20sending%20a%20screen%20recording%20of%20what%E2%80%99s%20happening.%20Any%20ideas%20what%E2%80%99s%20going%20on%20as%20it%E2%80%99s%20doing%20my%20head%20in%3F%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1336393%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOneDrive%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1493824%22%20slang%3D%22en-US%22%3ERe%3A%20One%20Drive%20and%20iOS%20Files%20app%20connection%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1493824%22%20slang%3D%22en-US%22%3E%3CP%3EHey%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F636186%22%20target%3D%22_blank%22%3E%40stevenjeve%3C%2FA%3E%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%E2%80%99ve%20just%20started%20having%20this%20same%20issue%2C%20and%20was%20wondering%20if%20you%20had%20ever%20discovered%20a%20fix%3F%20I%20tried%20logging%20out%20and%20logging%20back%20in%20on%20the%20One%20Drive%20app.%20This%20worked%20for%20a%20few%20minutes%20but%20when%20I%20switched%20apps%20and%20then%20came%20back%20I%20got%20the%20same%20error.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMuch%20appreciated%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETyler%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1500844%22%20slang%3D%22en-US%22%3ERe%3A%20One%20Drive%20and%20iOS%20Files%20app%20connection%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1500844%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F636186%22%20target%3D%22_blank%22%3E%40stevenjeve%3C%2FA%3E%26nbsp%3B%20Hi%2C%20I%20have%20the%20same%20problem%20just%20today.%20%26nbsp%3BDo%20you%20find%20out%20how%20to%20solve%20this%20problem%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1502241%22%20slang%3D%22en-US%22%3ERe%3A%20One%20Drive%20and%20iOS%20Files%20app%20connection%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1502241%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F636186%22%20target%3D%22_blank%22%3E%40stevenjeve%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20also%20running%20into%20the%20same%20problem%20I%20am%20on%20iOS%20beta.%20And%20I%20have%20two%20different%20drives%20one%20for%20Business%20and%20one%20for%20personal%20and%20they%E2%80%99re%20both%20having%20errors.%20I%20can%20access%20them%20on%20any%20other%20device%20but%20I%20have%20had%20issues%20for%20the%20past%20week%20or%20so%20trying%20to%20access%20the%20files%20from%20any%20app%20such%20as%20GoodNotes%20or%20the%20OneDrive%20app%20specifically.%20I%E2%80%99m%20trying%20to%20import%20some%20notes%20for%20work%20and%20I%20am%20running%20into%20a%20huge%20problem.%20I%20have%20an%20iPad%2010.2%20a.k.a.%20seventh%20GEN%20brand%20new.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1502195%22%20slang%3D%22en-US%22%3ERe%3A%20One%20Drive%20and%20iOS%20Files%20app%20connection%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1502195%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20starting%20the%20thread%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F636186%22%20target%3D%22_blank%22%3E%40stevenjeve%3C%2FA%3E.%20This%20same%20issue%20started%20bugging%20me%20today.%20I%20have%20been%20using%20the%20files%20app%20linked%20to%20my%20OneDrive%20account%20for%20months%20now%20on%20my%20iPad%20without%20any%20issues.%20Looking%20forward%20to%20someone%20that%20might%20shed%20light%20on%20this%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Regular Visitor

Hi, I’m using the iOS Files app to connect to One Drive. 
Recently I have experienced the following problem when trying to connect to One Drive.

Files app displays the error message, Content Unavailable. The folder contents could not be displayed because of an unknown error - try again.

I have deleted the One Drive and iOS Files app and reinstalled and tried to connect again but the problem continues. I have logged an issue with One Drive but we seem to be going around in circles and the agent doesn’t get the issue, even after sending a screen recording of what’s happening. Any ideas what’s going on as it’s doing my head in? 

51 Replies
Highlighted

Hey @stevenjeve

 

I’ve just started having this same issue, and was wondering if you had ever discovered a fix? I tried logging out and logging back in on the One Drive app. This worked for a few minutes but when I switched apps and then came back I got the same error. 

 

Much appreciated, 

 

Tyler 

Highlighted

@stevenjeve  Hi, I have the same problem just today.  Do you find out how to solve this problem?

 

 

Highlighted

Thanks for starting the thread @stevenjeve. This same issue started bugging me today. I have been using the files app linked to my OneDrive account for months now on my iPad without any issues. Looking forward to someone that might shed light on this issue.

Highlighted

@stevenjeve 

 

I am also running into the same problem I am on iOS beta. And I have two different drives one for Business and one for personal and they’re both having errors. I can access them on any other device but I have had issues for the past week or so trying to access the files from any app such as GoodNotes or the OneDrive app specifically. I’m trying to import some notes for work and I am running into a huge problem. I have an iPad 10.2 a.k.a. seventh GEN brand new.

Highlighted

@stevenjeve 

Having the same problem. Just trying to import a PDF from a specific OneDrive folder. Other folders in same OneDrive account are accessible. Using OneNote app on IPad Pro running 13.5.1 os

 

Highlighted
OK, semi-solution, at least for my issue. I made a new folder in OneDrive and moved the pdfs I was trying to upload to this new folder, then uploaded to OneNote from this new folder with no issues.
Highlighted
Same here since beginning of July. Guess either Apple or MS has change some protocol on the folder structure true.
Highlighted

@HenryAu  I am also facing the same issue for last couple of days. It was working well all the while, I am extensive user of Onedrive account in iPad and iOS. I would be grateful if apple or MS can resolve this issue at the earliest

Highlighted

Exactly the same problem here, @stevenjeve I tried to move content to subfolders, to other folders etc and it persists. folders with few files open fine, the mais folder, Documents, where I dump pretty much everything and folders with more the 50 files shows the error message:

Content Unavailable

The folder contents could not be displayed of an unknown reason

Try again  

 

The problem occurs in all my iOS devices. While it opens fine in Onedrive.app, I believe it could be a bug of the last version of this app. 

Highlighted

@stevenjeve 

 

Same issue on my iPad only. 

Oddly OneDrive within the iPhone Files app works just fine.

Strange behavior.

Need solutions.

Highlighted

@stevenjeve 

This has been happening randomly with my 2020 IPad Pro. I’ve not been able to duplicate the problem - but the last time it happened I was uploading two pdf files attached to an email in my gmail account.

The subdirectory contains over 50 pdf files. After I uploaded the two files, I got the error. In Files - but everything was ok in my One’Drive App

 

I figured out a work around. On another computer connected to my OneDrive account I created a new temporary folder and copied all the files from the affected directory to that temporary directory. When the Files App on my I Pad “saw” the temporary folder it opened Normally, Then I deleted the folder that wasn’t functioning and renamed the temp folder with the original name.

 

So far it’s working......

Highlighted

Thanks @Boooomer I tried the same . I created one dummy Sub folder folder and moved files  there .  It started working across all the iOS device now. However it is “ strange bug “ that Apple and MS needs to sort out .

 

 

Highlighted
I tried your workaround on my iPad Pro running iPadOS 13.5.1 but unfortunately it still doesn't work
Highlighted
Unfortunately it still doesn't work for me.
Highlighted
Hi , I read somewhere that due to high number of folders or files , iOS gets this error. Try consolidating all the folders and files in one subfolder and try again . It worked for me
Highlighted

@Muzeebur It works fine on my iPhone but not on my iPad which seems odd.  One problem is that the folders/files are my whole work desktop/documents.  Thousands of files.  Seems like a misstep by Microsoft/Apple here. 

Highlighted
i asked for technical support regarding the above issue via chat. did the delete app - soft reset - re-install app thing but they said it's a glitch in the onedrive app and wait for the next app update to have it solved? idk

it was working well until i had to update either my ipad or my onedrive app.
Highlighted
same here. it's my main "documents" and "must access everyday" folders that have issues
Highlighted

@tmbc2020 

 

Hi, Any folder has more than 50 files are not accessible by new update. We can access only upto 50 files In a folder . So workaround solutions for time being is create subfolder and move the files