Is there a 'one stop shop' for OD4B?

Highlighted
Regular Contributor

I just followed a link from a this Undated MS Page (bad msft)  https://support.office.com/en-us/article/Enable-users-to-sync-SharePoint-files-with-the-new-OneDrive... to the latest OneDrive client,  When I went to install it, it told me I had a later version already installed.   The version I have is 17.3.6798.0207 but it is not syncing my SharePoint Library.  Can I configure my version to Sync my SharePoint Library?   Will I be able to do this when I make a change in my admin center. 

The version syncing my sharepoint library is a versio of Groove.exe  16.0.4504.1000.  

 

I also has a bit of a 'loop' experience where I went to https://techcommunity.microsoft.com/t5/OneDrive-for-Business/bd-p/OneDriveforBusiness and I saw a link to NGSC17.3.6798.0207 which took me back to the page above which gives me a link to download an older version of OneDrive. 

 

What am I missing?

5 Replies
Highlighted

There are many things that could go wrong, unfortunately... ;)

 

First of all, the page you are referencing is an old one, which is about the NGSC preview.

The latest OneDrive client can be found here: https://support.office.com/en-gb/article/New-OneDrive-sync-client-release-notes-845dcf18-f921-435e-b...

BTW also the link in this page is not always updated as soon as the new versions are released. In any case, if are running Windows 10, leave OneDrive alone: it will upgrade automatically.

 

Second, if you are currently running Groove, for the existing syncs you should force the takeover by OneDrive or, better in my experience, perform the transition manually.

 

Third, have you configured SPO to use the new client?

 

Finally, can you please elaborate a bit on the problems you are experiencing? Probably someone here will be able to help...

Highlighted

Thanks Salvatore -  

The link you gave me https://support.office.com/en-gb/article/New-OneDrive-sync-client-release-notes-845dcf18-f921-435e-b... is what I was looking for.

 

If you do NOT change the sync client in SPO Admin Settings, is there a way to selectively force it's using for Syncing SharePoint Online libraries?

 

Grazie,

 

Greg

 

 

 

 

 

Highlighted

You're welcome!

AFAIK, you cannot add directly a SharePoint doclib to NGSC in order to sync it (instead with Groove you could do it ...).

Hence you are forced to use the sync button in the doclib, which works accordingly to the setting in the SPO Admin Center.

Highlighted
As always, Salvatore is correct :)
Highlighted

My wife would insist on the contrary... :-))