Folder Redirection - Not Happening

%3CLINGO-SUB%20id%3D%22lingo-sub-48960%22%20slang%3D%22en-US%22%3EFolder%20Redirection%20-%20Not%20Happening%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-48960%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20trying%20to%20test%20Folder%20Redirection%2C%20per%20the%20intructions%20at%20%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FRedirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c6c-4694-9f2f-fb8005d9ef12%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FRedirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c6c-4694-9f2f-fb8005d9ef12%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%3C%2FA%3E%20and%20it%20is%20not%20working.%20I%20have%20noticed%20that%20my%20Tenants%20name%20ends%20with%20a%20%22.%22%2C%20i.e%2C%20it%20is%20%22Tenant%2C%20Inc.%22%2C%20when%20I'm%20adding%20the%20Path%26nbsp%3Bto%20the%20Environment%20Variable%20in%20the%20Targeting%20Editor%2C%20clicking%20the%20elipses%2C%20allows%20me%20to%20select%20the%20OneDrive%20folder%2C%20and%20when%20it%20populates%20the%20text%20box%2C%20a%20hyphen%20is%20appended%20to%20the%20end.%20Should%20this%20be%20happening%3F%20is%20it%20possibly%20occurring%20because%20of%20the%20period%20at%20the%20end%20of%20the%20tenant%20name%3F%20this%20special%20character%20does%20not%20show%20up%20in%20the%20url%20of%20the%20ODfB%20site.%20After%20creating%20the%20variable%2C%20i%20did%20a%20gpudate%20%2Fforce%2C%20created%20a%20file%20in%20the%20Documents%20folder%20and%20it%20did%20not%20get%20synced%20to%20O365.%20Am%20I%20doing%20something%20wrong%3F%20Does%20anyone%20have%20any%20suggestions%20about%20how%20to%20troubleshoot%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-48960%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOneDrive%20for%20Business%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-167369%22%20slang%3D%22en-US%22%3ERe%3A%20Folder%20Redirection%20-%20Not%20Happening%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-167369%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20been%20working%20on%20Folder%20redirect%20for%202%20weeks%20and%20it%20has%20not%20worked%20for%20me.%20The%20folder%20does%20not%20get%20created%20hence%20sync%20not%20happening.%20Ive%20researched%20and%20can%20not%20find%20anyone%20with%20my%20problem.%20I've%20followed%20this%20guide%20all%20the%20way%20through%20%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FRedirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c6c-4694-9f2f-fb8005d9ef12%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2FRedirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c6c-4694-9f2f-fb8005d9ef12%3Fui%3Den-US%26amp%3Brs%3Den-US%26amp%3Bad%3DUS%3C%2FA%3E%20and%20I%20have%20used%20the%20updated%20OneDrive%20GPO%20template%20so%20I%20wouldn't%20have%20to%20edit%20anything.%20I%20have%20posted%20the%20full%20extent%20of%20what%20I%20have%20done%20to%20create%20and%20troubleshoot%20here%3A%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fwindows%2Fen-US%2Fe0c34520-4727-4a2d-9324-b294246f1e24%2Fonedrive-nextgen-sync-not-redirecting-folders-using-group-policy%3Fforum%3DwinserverGP%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fwindows%2Fen-US%2Fe0c34520-4727-4a2d-9324-b294246f1e24%2Fonedrive-nextgen-sync-not-redirecting-folders-using-group-policy%3Fforum%3DwinserverGP%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EIf%20anyone%20can%20help%20it%20will%20be%20greatly%20appreciated%20been%20scratching%20my%20head%20on%20this%20the%20last%202%20weeks.%20Sorry%20for%20posting%20this%20here%20I%20couldn't%20find%20a%20way%20to%20post%20on%20here.%3C%2FP%3E%0A%3CP%3EThanks%2C%20Manny%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-49023%22%20slang%3D%22en-US%22%3ERe%3A%20Folder%20Redirection%20-%20Not%20Happening%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-49023%22%20slang%3D%22en-US%22%3EI%20would%20suggest%20removing%20the%20%22.%22%20as%20it's%20probably%20not%20helping%20the%20matter.%3CBR%20%2F%3EA%20customer%20of%20mine%20had%20a%20similar%20issue%20as%20they%20had%20a%20%22%2F%22%20in%20their%20name%20-%20invalid%20character%20I%20know%2C%20but%20your%20period%20would%20potentially%20be%20adding%20to%20it.%3C%2FLINGO-BODY%3E
Highlighted
Respected Contributor

I am trying to test Folder Redirection, per the intructions at https://support.office.com/en-us/article/Redirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c... and it is not working. I have noticed that my Tenants name ends with a ".", i.e, it is "Tenant, Inc.", when I'm adding the Path to the Environment Variable in the Targeting Editor, clicking the elipses, allows me to select the OneDrive folder, and when it populates the text box, a hyphen is appended to the end. Should this be happening? is it possibly occurring because of the period at the end of the tenant name? this special character does not show up in the url of the ODfB site. After creating the variable, i did a gpudate /force, created a file in the Documents folder and it did not get synced to O365. Am I doing something wrong? Does anyone have any suggestions about how to troubleshoot?

 

2 Replies
Highlighted
I would suggest removing the "." as it's probably not helping the matter.
A customer of mine had a similar issue as they had a "/" in their name - invalid character I know, but your period would potentially be adding to it.
Highlighted

I've been working on Folder redirect for 2 weeks and it has not worked for me. The folder does not get created hence sync not happening. Ive researched and can not find anyone with my problem. I've followed this guide all the way through https://support.office.com/en-us/article/Redirect-known-folders-to-OneDrive-for-Business-e1b3963c-7c... and I have used the updated OneDrive GPO template so I wouldn't have to edit anything. I have posted the full extent of what I have done to create and troubleshoot here:

 

https://social.technet.microsoft.com/Forums/windows/en-US/e0c34520-4727-4a2d-9324-b294246f1e24/onedr...

 

If anyone can help it will be greatly appreciated been scratching my head on this the last 2 weeks. Sorry for posting this here I couldn't find a way to post on here.

Thanks, Manny