Files shared with Anyone sometimes prompt users to request acccess to the file

New Contributor

My company is experiencing an intermittent problem where sometimes a OneDrive for Business file shared with the setting "Anyone with this link can edit" prompts the user the file is being shared with to request access. If the user tries to open the file a second time, they can then access the file without requesting access. We're wondering why that access request prompt sometimes happens and how to prevent it. It doesn't happen consistently, so we're having trouble reproducing and troubleshooting it. Has anyone seen this before and know how to fix it?

76 Replies
I am also having this issue. I have embed links on my website and maybe 1 in 50 will be prompted to enter their login details to access when the downloads should be available for all.....so posting here in the hope there is an answer soon
Same here... sharing a link ('everyone with the link has access', without edit rights), and one of x users gets prompted...

When I sign out, I can access the link without issue on Mac and W7.

I strongly doubt this can't be reproduced... and the problem is not to trace what happens in detail, the point is to check in the code under which circumstances the user gets prompted when the owner has set the 'everyone with the link has access' flag... there must be some branch that (erroneously) makes this possible...

@Emily Mason 

Kind of same issue:

Go into my business One Drive online, right click on a folder to share,
change "Anyone with link can edit" to "Specific people" and uncheck "allow editing.
Click apply, then in next window type in one of business email addresses of a user.
Send the link, the user receives link in email, they click on the folder link,
chrome launches and they are asked to put in user credentials right away.
The standard Microsoft poup for "remember credentials", yes, then
user gets straight into the shared folder.

Every 2 days or so I get message from 2 to 3 end users that this folder has
been shared with, that One Drive is asking for credentials to login.
This is very annoying, we just don't hand out the login password to end users,
so everytime this happens I need to remote into their computer and add the credentials.

No idea why this happens, it seems to be after an update and restart to the computer,
or just a power off and restart.

I have gone into the credential manager and clicked on "remove" of Office and Microsoft credentials.
Still keeps happening.

Computer is updated, Chrome is updated, etc.

Same issue happening to me. Shared folder in OneDrive, selected Anyone with the link can edit, unchecked allow editing and put an expiration date to 6/1/2021. This morning received 5 email from users outside our organization, all of them saying the link is asking them to login. After reading this thread, I see how cached credentials in their browsers could cause an issue since it is supposed to be accessed "anonymously". Having said that, how do we fix this? asking external users to use Incognito mode in browsers, although it works, does not seem to be the most elegant solution, specially when we are talking about hundreds of users accessing these folders. I don't want to suggest my staff to use Dropdbox, please help find a solution!
A data point: The problem continues to happen even though I'm using a completely new install of Windows on a completely new computer (not using same Windows-image).
This is just unbelievable.
I switched my whole Cloud setup to OneDrive and now have to realize that File Sharing is simply completely buggy and not usable.
Minimum 50% of the users I share links with are not able to download.
When sharing folders and not files it ALWAYS happens, so doesn't even seem to be possible.
When trying to debug I found that in Opera browser it ALWAYS asks for login as well.

Expecting OneDrive is a fully developed solution, this is very frustrating.
I think I have no choice but to switch to another Cloud Storage.
Getting eMails from users not being able to access files is just not a possibility.

Just ran into this and I am going to suggest a possible conflict. Thank you all for your contributions because it gave me some perspective. I suspect that it is an issue of how MSoft is applying the permissions - or more particularly in what order. 

 

What seems reasonable to me is that if the user is logged on to the system and when the file is first accessed it occasionally tries to see if the user has access initially rather than using the link's permissions. In other words it does not follow this order  

1 - does the link give access

2 - does the user have access

rather

1 - does the user have access (chokes)

2 - does the link give access

The idea is that the document may have multiple ways to grant access and the order is important. If it chokes before considering all paths (as it might if it checks for user first) it would prevent the access the link would give.

Just a thought...

:)

We also have this issue. Wanted to comment here and follow this thread.

Hi, I recently encountered this issue and realized that it happens when sharing large files.  @Stephen Rice 

forget this comment...I tried larger files than the one with the error and the link worked, so the process of elimination discredits the aforementioned theory...however, trial and error has shown that sharing the problematic file simultaneously with another file, as plain as a .txt, makes the problematic link work. Strangely.

Just adding to the thread that we've been experiencing this issue as well.  I have no idea how widespread it is, I just know that I often send out links to internal users and every so often I see a request to access the file, even though I have setting to allow anyone to view/edit with the link.

 

I don't believe any file I have ever shared outside the organization has ever come back with a request for access.

Hi everyone, hi @Stephen Rice. I'm having the same problem. In my case, I need to use the URLs so that an external program will download the images and update as product pictures on marketplaces. The issue seems pretty random, though. Some photos will be accessible, while others will require a login. I tested uploading the URLs to two different webisites (400 pics in total). Some of them will be available at one site, other will be available at another... There isn't a consistency.
Hey again. Sorry if I'm being such a noob :D
But I kinda figured out how to solve my problem. The thing is that if I copied the URL from my computer (my onedrive user) and another person tried to upload it through their computer (another user), the marketplace wouldn't be able to download the photo, promping an access request. If I, who copied the URL, tried to upload it, the marketplace would access the picture just fine.

In fact, two URLs from the same picture are different (one that I copied from my user, and the other that other person copied, using a different user). Didn't know that could happen. I hope it helps.

@Stephen Rice I don't know if this has made any further traction in the Microsoft teams, but I am having this problem and just opened a Support case to investigate. Mine is very consistent and I have a few sample links I can share in a document to demonstrate the issue under various conditions. When using the links, the user is prompted to login whenever they attempt to access a file. The behavior is slightly different depending on the file type and depending on whether they access a file or a folder. This can be easily verified by opening the links using an Incognito window to ensure there are no issues with authentication tokens or other tenancy.

@Cameron Gocke I have had a ticket open for months, with no progress. They want me to recreate the issue while logging, but it is random and I actually haven't had the issue for a while. Let me know if you make any progress with your ticket. I even referenced this thread.

This feels like a no go thing. Might as well use a free file sharing platform. It's absolutely convoluted and a waste of time. I have tried various configurations including emailing myself personally. All links require authentication. The document I produced is riddled with links and is used for onboarding new clients prior to them getting log on crendential. Perhaps it's time to create a new dropbox account for this purpose. Stress!!

Incredibly irritating. The simplest possible thing . . . share this file to anyone with the link . . . and you can't do it without them being prompted to log in. Ridiculous. I just had to pony up for a year's worth of Google Drive because I can't get this simple operation to work on the OneDrive that I already pay for.

So my problem may have been slightly different in some way, but after some back and forth a Support person said they had to run a script to "synchronize the file sharing" on the back end and after they did this all of the file sharing started working. I believe even the original file sharing links that had been created started working as expected. I have no idea what that script was, but it certainly reinforces the notion that Office 365 is held together by a bunch of PowerShell scripts strung together.
This issue is still occurring in 2022. I have a series of documents that are shared to different groups as a link that's "available to anyone who has the link". Some individuals are prompted to request access even though the settings are correct and I've personally checked that they're accessible as a guest.

@Stephen Rice  Has any progress been made on this issue? I'm not a tech person, just a member of the comms team, and we are having the same problem: We share a file with a group of people, we give them permission to edit (before copying the link to share), and then they end up having to request access. Very frustrating. It's March 2022... has been going on for years, now. Has anyone solved the bug?