[UI change suggestion] Rename "Always keep on this device" to "Download a copy to this device"

Brass Contributor

Based on this discussion: 



I think that part of the problem is the misleading term Always keep on this device - that's not really what the function does, it just downloads a copy in the same way that opening a non-cached file does. Always keep on this device is ambiguous regarding the concepts of copies vs originals, and copying vs moving, and this builds an incorrect mental model in the user's mind that leads to fundamental misunderstanding of the concepts involved. The current wording implies that there ought to be an Always keep in the cloud option too, which (I think) is what @jasonhand was asking.


I think the design would be clearer if the function was labelled Download a copy to this device because:

  1. That's what is actually does
  2. It's more aligned with what happens when you open a cloud-only file
  3. It helps build a better model in the user's mind
0 Replies