Installing with Office Deployment Tool: MsoGetRemoteHostNetworkStatusWithUrlType failed

%3CLINGO-SUB%20id%3D%22lingo-sub-375714%22%20slang%3D%22en-US%22%3EInstalling%20with%20Office%20Deployment%20Tool%3A%20MsoGetRemoteHostNetworkStatusWithUrlType%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-375714%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22%22%3EI%20am%20using%20the%20Office%20Deployment%20Tool%20with%20my%20C2R%20installer%20for%20Office%20Professional%20Plus%202016%20Student%20Option%20(PID%3D%22ProPlus2016Volume%22%2C%2032-bit)%20to%20selectively%20exclude%20the%20Office%20products%20I%20don't%20use.%20I%20successfully%20downloaded%20the%20file%20folder%20'Office'%20to%20my%20SourcePath%20(Downloads%20folder)%20using%20the%20command%20'setup.exe%20%2Fdownload%20configuration.xml'%20on%20the%20configuration%20file%20produced%20by%20the%20online%20ODT%20XML%20Editor.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20when%20I%20run%20the%20next%20command%2C%20'setup.exe%20%2Fconfigure%20configuration.xml'%2C%20I%20first%20get%20a%20pop-up%20window%3A%20%22User%20Account%20Control%3A%20Do%20you%20want%20to%20allow%20this%20app%20to%20make%20changes%20to%20your%20device%3F%22%20After%20I%20click%20'yes%2C'%20the%20orange%20Office%20startup%20window%20%22We're%20getting%20things%20ready%22%20shows%20for%202%20seconds%20before%20the%20process%20exits%20(I%20monitored%20this%20in%20Task%20Manager).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20of%20the%20process%20logs%20have%20the%20following%20(only)%20error%3A%3C%2FP%3E%3CP%3E03%2F15%2F2019%2017%3A01%3A43.916%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3ESETUP%20(0x1058)%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E0x854%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3ENexus%20Transport%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Ea426j%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3EMonitorableMsoGetRemoteHostNetworkStatusWithUrlType%20failed%20%7B%22RemoteHost%22%3A%20%22%3CA%20href%3D%22https%3A%2F%2Fnexus.officeapps.live.com%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fnexus.officeapps.live.com%3C%2FA%3E%22%7D%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20process%20tries%20and%20fails%20this%20step%20multiple%20times%20before%20exiting%20the%20installation.%20My%20installation%20for%20MS%20Office%20is%20on%20a%20Windows%2010%20virtual%20machine%20(VMware%20Fusion)%20on%20macOS%20Mojave.%20Since%20this%20looks%20like%20a%20network%20issue%2C%20I%20have%20tried%20disabling%20the%20firewall%20on%20both%20OSes%20without%20any%20luck%2C%20and%20I'm%20not%20using%20proxies.%20I%20have%20a%20strong%20internet%20connection%2C%20although%20I%20don't%20know%20why%20the%20installer%20is%20looking%20online%20when%20I%20have%20the%20files%20already%20downloaded%20locally.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20have%20any%20ideas%20for%20how%20I%20could%20fix%20this%3F%20I've%20searched%20Community%20and%20Google%20thoroughly%20and%20found%20similar%2C%20but%20not%20identical%2C%20problems%20and%20solutions%20that%20didn't%20end%20up%20working.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-508109%22%20slang%3D%22en-US%22%3ERe%3A%20Installing%20with%20Office%20Deployment%20Tool%3A%20MsoGetRemoteHostNetworkStatusWithUrlType%20failed%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-508109%22%20slang%3D%22en-US%22%3E%3CP%3EI%26nbsp%3Bam%20having%20the%20same%20issue%20and%20get%20the%20same%20error%2C%20but%20only%20when%20I'm%20installing%20Visio%202016%20via%20the%20deployment%20tool.%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F301914%22%20target%3D%22_blank%22%3E%40NDJ80%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

I am using the Office Deployment Tool with my C2R installer for Office Professional Plus 2016 Student Option (PID="ProPlus2016Volume", 32-bit) to selectively exclude the Office products I don't use. I successfully downloaded the file folder 'Office' to my SourcePath (Downloads folder) using the command 'setup.exe /download configuration.xml' on the configuration file produced by the online ODT XML Editor.

 

However, when I run the next command, 'setup.exe /configure configuration.xml', I first get a pop-up window: "User Account Control: Do you want to allow this app to make changes to your device?" After I click 'yes,' the orange Office startup window "We're getting things ready" shows for 2 seconds before the process exits (I monitored this in Task Manager).

 

All of the process logs have the following (only) error:

03/15/2019 17:01:43.916 SETUP (0x1058) 0x854 Nexus Transport a426j MonitorableMsoGetRemoteHostNetworkStatusWithUrlType failed {"RemoteHost": "https://nexus.officeapps.live.com"}

 

The process tries and fails this step multiple times before exiting the installation. My installation for MS Office is on a Windows 10 virtual machine (VMware Fusion) on macOS Mojave. Since this looks like a network issue, I have tried disabling the firewall on both OSes without any luck, and I'm not using proxies. I have a strong internet connection, although I don't know why the installer is looking online when I have the files already downloaded locally.

 

Does anyone have any ideas for how I could fix this? I've searched Community and Google thoroughly and found similar, but not identical, problems and solutions that didn't end up working.

1 Reply

I am having the same issue and get the same error, but only when I'm installing Visio 2016 via the deployment tool.@NDJ80