Installing with Office Deployment Tool: MsoGetRemoteHostNetworkStatusWithUrlType failed

Occasional Visitor

I am using the Office Deployment Tool with my C2R installer for Office Professional Plus 2016 Student Option (PID="ProPlus2016Volume", 32-bit) to selectively exclude the Office products I don't use. I successfully downloaded the file folder 'Office' to my SourcePath (Downloads folder) using the command 'setup.exe /download configuration.xml' on the configuration file produced by the online ODT XML Editor.

 

However, when I run the next command, 'setup.exe /configure configuration.xml', I first get a pop-up window: "User Account Control: Do you want to allow this app to make changes to your device?" After I click 'yes,' the orange Office startup window "We're getting things ready" shows for 2 seconds before the process exits (I monitored this in Task Manager).

 

All of the process logs have the following (only) error:

03/15/2019 17:01:43.916 SETUP (0x1058) 0x854 Nexus Transport a426j MonitorableMsoGetRemoteHostNetworkStatusWithUrlType failed {"RemoteHost": "https://nexus.officeapps.live.com"}

 

The process tries and fails this step multiple times before exiting the installation. My installation for MS Office is on a Windows 10 virtual machine (VMware Fusion) on macOS Mojave. Since this looks like a network issue, I have tried disabling the firewall on both OSes without any luck, and I'm not using proxies. I have a strong internet connection, although I don't know why the installer is looking online when I have the files already downloaded locally.

 

Does anyone have any ideas for how I could fix this? I've searched Community and Google thoroughly and found similar, but not identical, problems and solutions that didn't end up working.

1 Reply

I am having the same issue and get the same error, but only when I'm installing Visio 2016 via the deployment tool.@NDJ80