Unable to load office documents over HTTPS

%3CLINGO-SUB%20id%3D%22lingo-sub-1326154%22%20slang%3D%22en-US%22%3EUnable%20to%20load%20office%20documents%20over%20HTTPS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1326154%22%20slang%3D%22en-US%22%3E%3CP%3EServer%20-%20Windows%20Server%202012%20R2%3C%2FP%3E%3CP%3EOffice%20Online%20Build%20Version%20-16.0.8471.8525%3C%2FP%3E%3CP%3EWeb%20Application%20tomcat%20version%20-%209%3C%2FP%3E%3CP%3EWeb%20Application%20language%20-%20Javascript%20and%20Java%201.8%3C%2FP%3E%3CP%3EMicrosoft.NET%20framework%20installed%20%26nbsp%3Bon%20office%20online%20server%20-%20V4.0.3%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOur%20Web%20Application%20and%20the%20office%20online%20are%20located%20at%20the%20same%20server%20.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20are%20able%20to%20work%20with%20office%20documents%20via%20http%20in%20the%20application%20currently%20without%20issues%20with%20all%20the%20necessary%20configuration%20in%20the%20office%20Web%20Apps%20farm%20.%3C%2FP%3E%3CP%3EWe%20recently%20included%20SSL%20in%20the%20web%20Application(using%20Tomcat%20Server%20)%20And%20Also%20configured%20it%20on%20the%20IIS%20and%20have%20it%20binded%20%26nbsp%3Bto%20the%20SSL%20port%20.%20The%20certificate%20is%20domain%20specific%20and%20we%20got%20it%20purchased%20from%20comodo%20.%20And%20the%20certificate%20seems%20to%20be%20configured%20on%20the%20Office%20Web%20Apps%20farm%20following%20the%20official%26nbsp%3B%20Microsoft%20documentation%20.%20We%20did%20try%20the%20https%3A%2F%2F%20Domain%2Fop%2Fgenerate.aspx%20test%20to%20load%20the%20document%20and%20that%20worked%20with%20the%20https%20and%20office%20docs%20loaded%20fine%20.Right%20now%20when%20we%20try%20to%20open%20any%20existing%20office%20document%20through%20the%20Web%20Application%20we%20are%20unable%20to%20load%20it%20in%20the%20Iframe%20and%20we%20are%20an%20exception%20saying%20%22Sorry%20the%20document%20cannot%20be%20loaded%20%22%26nbsp%3B%20.%20Checking%20the%20ULS%20logs%20we%20found%20this%20error%20to%20appear%20every%20time%20we%20try%20to%20open%20any%20existing%20office%20Document%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3BULS%20Logs%20Error%20%3A%20wac-server%3A%20WOPI%20CheckFile%3A%20Catch-All%20Failure%20%5Bexception%3AMicrosoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException%3A%20WOPI%20400.%20Wopi%2CCheckFile%2CWACSERVER%20---%26gt%3B%20System.Web.HttpException%3A%20BadRequest%20---%26nbsp%3B%20---%26nbsp%3B%20Microsoft.Office.Web.Apps.Common.WopiDocument.LogAndThrowWireException(HttpRequestAsyncResult%20result%2C%20HttpRequestAsyncException%20delayedException)%20%D0%B2%20Microsoft.Office.Web.Common.HttpRequestAsync.End()%20%D0%B2%20Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()%5D%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1326154%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Visitor

Server - Windows Server 2012 R2

Office Online Build Version -16.0.8471.8525

Web Application tomcat version - 9

Web Application language - Javascript and Java 1.8

Microsoft.NET framework installed  on office online server - V4.0.3

 

 

Our Web Application and the office online are located at the same server .

 

We are able to work with office documents via http in the application currently without issues with all the necessary configuration in the office Web Apps farm .

We recently included SSL in the web Application(using Tomcat Server ) And Also configured it on the IIS and have it binded  to the SSL port . The certificate is domain specific and we got it purchased from comodo . And the certificate seems to be configured on the Office Web Apps farm following the official  Microsoft documentation . We did try the https:// Domain/op/generate.aspx test to load the document and that worked with the https and office docs loaded fine .Right now when we try to open any existing office document through the Web Application we are unable to load it in the Iframe and we are an exception saying "Sorry the document cannot be loaded "  . Checking the ULS logs we found this error to appear every time we try to open any existing office Document:

 

 ULS Logs Error : wac-server: WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI 400. Wopi,CheckFile,WACSERVER ---> System.Web.HttpException: BadRequest ---  ---  Microsoft.Office.Web.Apps.Common.WopiDocument.LogAndThrowWireException(HttpRequestAsyncResult result, HttpRequestAsyncException delayedException) в Microsoft.Office.Web.Common.HttpRequestAsync.End() в Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()]

0 Replies