single user cannot access public folders in hybrid mode

Occasional Contributor

I have a  single user in a hybrid O365 environment (Exchange 2013) that has been migrated to 365, that doesn't have access to the public folders on the exchange 2013 server, he gets the error:

Cannot expand the folder.  The attempt to log on to Microsoft Exchange has failed

other users who have been migrated to 365 CAN see the folders.  they all have reviewer rights.

it is a public folder that contains external email addresses, so they can share an address book of people\vendors outside the company.

I have tried changing permissions on the folder, even made him owner from  Exchange 2013 ECP but still cannot expand the folder without getting that error.

I have tried recreating his profile with no change.

I have set him up on another system, with no change.

I even went to ECP and manually gave him reviewer rights to Public Folders from there (this is the only public folder in use) but no change.

what else can I try?


4 Replies

Have you tried this in O365:-

Set-OrganizationConfig -PublicFoldersEnabled Remote -RemotePublicFolderMailboxes PFMailbox

This will configure the mailboxes on Office 365 to use On-Premises Public Folders. You need to provide your on prem PF mailbox in place of PFMailbox, you can provide multiple values like this :-PFMailbox1,PFMailbox2,PFMailbox3.

I have done that already.  I have mutliple uses who CAN access the Public Folders, just this one who cannot, and I cant seem to figure it out.

even tried setting x500 email address, but that did not work, and I did notice that other users did not have x500.



@admiral_suluI am having this issue too with a single user and the rest of the organisation still able to access on-premise Public Folders. Did you manage to fix it in your environment? If so, how?


never found a resolution, just replaced the public folder address book with a 365 shared mailbox address book.