SharePoint Online Document Library Name and Spaces

Occasional Contributor

There seems to be an issue with inputting spaces when creating a new document library. For example, if you want to put a space in between the capitalized letters, it will not let you - DocumentLibraryTest. If you hit the space bar in between it does not take it as input. 

 

Workaround:

 

Move your cursor in between characters after you have typed the document library name without spaces and then press the space bar.

7 Replies
Thank you. I have created a library and deleted it twice because it messes up the document template for this library.
Has anyone figured out what happened and when will it be resolved?
By the way thank you Tristan999. I thought something was wrong with my site or keyboard.
I'm not exactly sure when it will be fixed. Your best bet is to create a ticket with Microsoft.

Just ran into this problem today in the middle of a demo.  Thought I was losing my mind.  Glad to know of the workaround.  Hoping it gets fixed soon...

Hello, @Tristan999, I would not say it is an issue. It is the feature not to see such links as a result: http://nakivo/Shared%20Documents/July%20meetinf/Rek2%20Stjndard%20Qdote%20ffr%20clifnt.xls

 

As you understand, the URLs can't contain the spaces, so the system has to add "%20". I also wanted to troubleshoot the same problem, and here is what I have found out.

 

While creating the Shared Documents library, put the name as "SharedNakivoDocuments" with no spaces, and then, go back to the configuration and change the name to a more convenient name with the spaces. This is it.

 

If you want to learn more details on every step, check this link: https://www.c5insight.com/Resources/Blog/tabid/148/entryid/421/Dont-Use-Spaces-When-Naming-Things-in...

 

Another recommendation is to use a solid Microsoft 365 backup tool not to lose your organization's data at the most unpredictable moment. You may check this solution.

@Terry_Lazer You must have misunderstood:

 

I am talking about this field:

 

Tristan999_0-1654312304537.png

 

The bug is that the input field does not allow you to put in the space characters as you type the library name.

 

You need to put your cursor where you want to inject the spaces in the library name:

 

Tristan999_1-1654312392050.png

 

So, it is an issue. 

 

 

 

@Tristan999 

 

The issue also applies to the Description field, which is weird. My guess is that the Title tries to restrict spaces for the reason @Terry_Lazer gave, but the restrictions were also applied to the Description field, which feels like an accident.

 

Easier workaround

  1. Type a character into the input box
  2. Move your cursor before the character
  3. Type in your Title/Description (you can now add spaces if you want)
  4. When you're done, delete the extra character

@MehtaData,

 

It's definitely a bug.

 

From what I've read on the SharePoint reddit forum:

 

https://www.reddit.com/r/sharepoint/comments/ut8h5m/cant_type_a_space_in_new_document_library_name/

 

I've tried it on another tenant and the spaces work in both the Title and the Description. The one where it works is an E5 tenant vs where it doesn't work, an E3 tenant. You might have to pay extra for the spaces... :p joking.