SOLVED

SharePoint Event Web Part Doesn't Work

Contributor

I have several calendar lists on a team SharePoint site and wanted to display them using the Event Web Part on the Homepage. I created one Event Web and it worked fine with one of the calendars. I created a second one (I wanted the events to be viewed separately) and it fails to recognize events in three of the Calendars. The other two work fine, but not the one I need. All of the settings for the calendars are identical and I have repeated the error using other browsers on other networks and other computers.

 

What am I doing wrong?

2018-10-26 09_56_43-Window.png


2018-10-26 09_57_55-Window.png

 

34 Replies
Not without manually opening the items individually.

When did you first experience this @John Lathbury @Ramy Farag ? This suddenly started at one of our clients tenant in the period between 20-28 october but they are not sure.

 

Ole

I noticed it yesterday and this was my first time using flow to create an event. It is happening on couple of tenants.

I'm not sure when it started. This has affected my Flow created events from the beginning, but I only put that flow together in October.

best response confirmed by John Lathbury (Contributor)
Solution

I found out that the Events web part requires the field "All Day Event" to have a value, either true or false to show the event (it is blank when we initially create the event). To update this field in Flow after creating the event, we need to use REST API using the "Send an HTTP request to SharePoint" action. Once you assign a value to the field, the event will show up in the Events web part. Please reference the below link (Mark Invites as Full Day Event section) for the steps to set the "All Day Event" field in Flow.

 

SEND MEETING INVITES TO SHAREPOINT ONLINE CALENDAR

 

I added the fAlldayEvent to the rest call. I actually ended up doing it all using the rest call action. thx for the tip:) That tip should be set as best solution @John Lathbury

I've been fighting with this all day and I can't seem to get it to work.

I'm sure I making a mistake but I can't seem to find where.

2018-11-12 14_30_21-Edit your flow _ Microsoft Flow.png

This is what I get each time:
{"status": 400"message": "The expression \"web/lists/getbytitle(‘Birthdays and Anniversaries’)/items(1689)\" is not valid.\r\nclientRequestId: cebef768-c985-463c-b69f-14b8ecc36129\r\nserviceRequestId: 8ebba19e-30b9-7000-07b6-538e305b00f3",
"source": "https://SITEURL/_api/web/lists/getbytitle(%E2%80%98Birthdays%20and%20Anniversaries%E2%80%99)/items(1689)""errors": [ "-1""Microsoft.SharePoint.Client.InvalidClientQueryException" ]}
I could be wrong - but in your URI field, try deleting and re-typing the ' marks around Birthdays and Anniversaries - I think you have pasted them in from somewhere and it has taken some formatting with it.
*Facedesk*
I'll change that and give it a try. Thanks!

1- Since your list name has spaces. In the REST API use _x0020_ to represent the spaces. So your Body JSON should be

 

{
"__metadata": {
"type" : "SP.Data.Birthdays_x0020_and_x0020_AnniverseriesListItem"},
"fAllDayEvent" : "False"
}

2- If you are setting the fAlldayEvent to True, you must also set the EventDate and EndDate similar to the blog I included otherwise you will get an error

 

 

 

Thank you!
I wasn't thinking and tried %20 instead of _x0020_
It works perfect now!

With regards to the fAlldayEvent i actually had to create an initial condition checking the all day event or not. I couldn't use the parameter from the trigger since it constantly stated True or False with capital lettering so i created a variable that got set to fAllDayEvent: true if the trigger parameter was True and vice versa.

logicAppFAllDay.jpg

BTW, i'm using Logic Apps 

 

 

Spaces in SharePoint are evil, and the cause of untold amount of frustration. Try to avoid them when creating new sites, libraries, and lists.

I have been having a heck of a time with this webpart. On SP2013 I created a list webpart that showed who was out of th eoffice today. The events web part does not have a "today" option. I have tried using the category filter and flow to update the list and no luck. Plus you can't customize to show only the fields you want. I would like to simply create a list webpart but you can't do that on an event list in sharepoint online. Any way I can get a webpart to simply show me Today's events? @John Lathbury 

Hi @John Lathbury I actually do the same thing as you and would like to display events from different pages with a filtered category on a hub site. I also have the problem that some events are simply not displayed.
In my case the "About this item" field / column in the event caused the error. I haven't found out exactly what it is, but if I delete the text completely, the event is suddenly displayed again. For example, he did not display an event when a German letter "ä" (ae) was very close to the front of the text. At the end of the text it worked again. "Das nächste CARES Audit ist das sogenannte Nachhaltigkeits-Audit (Sustainability). Es wird aller Voraussicht nach als Remote-Audit stattfinden, d.h. über Teams." deleted after the letter "ä". The event was then displayed. Strangely enough, the following text does not work without the letter "ä" "Das naechste CARES Audit ist das sogenannte Nachhaltigkeits-Audit (Sustainability). Es wird aller Voraussicht nach als Remote-Audit stattfinden, d.h. ueber Teams. " But the following letters (text) "fsfwä thrth j tjt hj thj fhdj k iul ojmdy gjjjttz juzzjzu rtui kzrt z tzu j  rthh tzztj tzjtzjtzj tj tzj tzj ä" is no problem and the event will be displayed.
So I still don't know why that could be, but the text in "About his item" is causing problems.

 

Maybe someone knows about the problem and could explain it to me.