Shared Mailbox Send As issues

New Contributor

I work for one company that has their own email host and am using an Exchange account there.  I also own and manage a domain hosted in O365 (related business) and have both set up within the same desktop Outlook.  Shared mailboxes on the external host are actually set up as users with full permissions granted to applicable people (their structure, not my choice) and work good with sending as the mailbox.

 

The issue is that I have also created Shared Mailboxes in the O365 hosted and it appeared just fine (automatically) and can receive and view email just fine, but whenever I try to send an email as the shared mailbox it gives the below returned email:

 

            This message could not be sent. You do not have the permission to send the message on behalf of the specified user.

 

__________________________________________________

 

Diagnostic information for administrators:

__________________________________________________

 

Error is [0x80070005-0x000004dc-0x00000524].

 

Exchange response headers:

      request-id: aae735ff-61a0-4303-8308-9b92431ba2c9

      X-ServerApplication: Exchange/15.01.2308.020

      X-FEServer: PRDH02EXCH06

      X-BEServer: AUSH02EXCH05

      X-CalculatedBETarget: aush02exch05.h02.hostedmail.local

      X-RequestId: {239F18EC-9F78-4274-B8BB-AACBBF2D6480}:34

      X-ClientInfo: {FE2C7307-DA5C-4819-8A5A-AB654815073B}:19440066

      X-ElapsedTime: 40

      X-ResponseCode: 0

      X-DiagInfo: AUSH02EXCH05

      X-RequestType: Execute

__________________________________________________

 

ROPs Summary:

 

      0: ropSetProps (10) Processed(1) Completed(0)

            ROP result: 0

            Response codes: 0

      1: ropSetProps (10) Processed(1) Completed(0)

            ROP result: 0

            Response codes: 0

      2: ropFlushRecipients (14) Processed(1) Completed(0)

            ROP result: 0

            Response codes: 0

      3: ropSetProps (10) Processed(1) Completed(0)

            ROP result: 0

            Response codes: 0

      4: ropTransportSend (74) Processed(1) Completed(0)

            ROP result: 0

            Response codes: 1244

__________________________________________________

 

Response Exceptions:

 

ROP Index: 4

ROP Associated: ropTransportSend (74)

Microsoft.Exchange.Data.Storage.SendAsDeniedException: Can't transport send message. ---> Microsoft.Mapi.MapiExceptionSendAsDenied: MapiExceptionSendAsDenied: Unable to transport send message. (hr=0x80070005, ec=1244)

Diagnostic context:

    ......

    Lid: 52176   ClientVersion: 15.1.2308.20

    Lid: 50032   ServerVersion: 15.1.2308.6020

    Lid: 35180 

    Lid: 23226   --- ROP Parse Start ---

    Lid: 27962   ROP: ropFlushRecipients [14]

    Lid: 27962   ROP: ropFlushRecipients [14]

    Lid: 31418   --- ROP Parse Done ---

    Lid: 55847   EMSMDBPOOL.EcPoolSessionDoRpc called [length=166]

    Lid: 43559   EMSMDBPOOL.EcPoolSessionDoRpc returned [ec=0x0][length=456][latency=3]

    Lid: 52176   ClientVersion: 15.1.2308.20

    Lid: 50032   ServerVersion: 15.1.2308.6020

    Lid: 35180 

    Lid: 23226   --- ROP Parse Start ---

    Lid: 27962   ROP: ropSetProps [10]

    Lid: 27962   ROP: ropTransportSend [74]

    Lid: 17082   ROP Error: 0x4DC    

    Lid: 44949 

    Lid: 21921   StoreEc: 0x4DC    

    Lid: 27962   ROP: ropExtendedError [250]

    Lid: 1494    ---- Remote Context Beg ----

    Lid: 1238    Remote Context Overflow

    Lid: 57132   qdwParam: 0x0              

    Lid: 36423   dwParam: 0x0        Msg: /o=ExchangeLabs/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=e2b94478e7da4981b8c

    Lid: 42092   StoreEc: 0x4DC    

    Lid: 33900 

    Lid: 45434   Guid: 59a65903-75b3-491a-bb25-4b628107efde

    Lid: 10786   dwParam: 0x0        Msg: 15.01.2308.020:aush02exch05:0c665abf-774e-4624-a7a2-5e643ce17afc

    Lid: 1750    ---- Remote Context End ----

    Lid: 31418   --- ROP Parse Done ---

    Lid: 22753 

    Lid: 21817   ROP Failure: 0x4DC    

    Lid: 59285 

    Lid: 46997   StoreEc: 0x4DC    

   at Microsoft.Mapi.MapiExceptionHelper.InternalThrowIfErrorOrWarning(String message, Int32 hresult, Boolean allowWarnings, Int32 ec, DiagnosticContext diagCtx, Exception innerException)

   at Microsoft.Mapi.MapiExceptionHelper.ThrowIfError(String message, Int32 hresult, IExInterface iUnknown, Exception innerException)

   at Microsoft.Mapi.MapiMessage.TransportSendMessage(PropValue[]& propsToReturn)

   at Microsoft.Exchange.Data.Storage.MapiAccessor.TransportSendMessage(MapiMessage mapiMessage, PropValue[]& mapiPropValues)

   --- End of inner exception stack trace ---

   at Microsoft.Exchange.Data.Storage.MapiAccessor.TransportSendMessage(MapiMessage mapiMessage, PropValue[]& mapiPropValues)

   at Microsoft.Exchange.Data.Storage.CoreItem.TransportSend(PropertyDefinition[]& propertyDefinitions, Object[]& propertyValues)

   at Microsoft.Exchange.RpcClientAccess.Handler.Message.TransportSend()

   at Microsoft.Exchange.RpcClientAccess.Handler.RopHandler.<>c__DisplayClass153_0.<TransportSend>b__0()

   at Microsoft.Exchange.RpcClientAccess.Handler.ExceptionTranslator.TryExecuteCatchAndTranslateExceptions[TResult](Func`1 protectedCode, Func`2 errorCodeExtractor, Boolean noThrow, TResult& result, Exception& exception, ErrorCode& errorCode)

 

 

Transport-Send failed: failure enum(25), HResult(0x00000000), EC(1244).

Transport-Send failed: failure enum(22), HResult(0x00000000), EC(1244).

Submit-Message failed: message id(1), failure enum(13), HResult(0x80070005), EC(1244).

1 Reply
1) Did you grant yourself "Send As" right?
2) Can you send as a shared mailbox in OWA?