SOLVED

Set-User xxx -PermanentlyClearPreviousMailboxInfo not working?

%3CLINGO-SUB%20id%3D%22lingo-sub-216284%22%20slang%3D%22en-US%22%3ESet-User%20xxx%20-PermanentlyClearPreviousMailboxInfo%20not%20working%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-216284%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3Eregarding%20that%20article%20(%3CA%20href%3D%22https%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F01%2F17%2Fpermanently-clear-previous-mailbox-info%2F%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fblogs.technet.microsoft.com%2Fexchange%2F2018%2F01%2F17%2Fpermanently-clear-previous-mailbox-info%2F%3C%2FA%3E)%20the%20command%20was%20introducted%20to%20remove%20mailbox%20information%20in%20office%20365%20in%20hybrid%20scenarios%20where%20online%20mailboxes%20exist%20before%20azure%20ad%20connect%20%2F%20exchange%20hybrid%20was%20implemented.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20ever%20someone%20used%20that%20parameter%3F%20I%20used%20it%20and%20after%20confirming%20the%20deletion%20it%20says%20%22completed%2C%20but%20nothing%20changed%22%20and%20really%20nothing%20happened%20-%20the%20mailbox%20is%20still%20there%20in%20EXO%3F!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20had%20similar%20or%20different%20experiences%20with%20it%3F%20Unfortunately%2C%20you%20can%20only%20find%20the%20articles%20from%20the%20beginning%20of%20the%20year%20where%20the%20parameter%20was%20presented.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EKind%20regards%3C%2FP%3E%3CP%3EPatrick%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-216284%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHybrid%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-238503%22%20slang%3D%22en-US%22%3ERe%3A%20Set-User%20xxx%20-PermanentlyClearPreviousMailboxInfo%20not%20working%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-238503%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20solution%20is%20to%20uncheck%20the%20EXO%20license%20before%20running%20the%20command.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-216660%22%20slang%3D%22en-US%22%3ERe%3A%20Set-User%20xxx%20-PermanentlyClearPreviousMailboxInfo%20not%20working%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-216660%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EI%20get%20a%20feedback%20like%20%22please%20confirm...%20deleting%20mailbox%20etc.%22%20and%20when%20I%20typ%20Y%2C%20it%20says%20%22Completed%2C%20but%20nothing%20changed%20for%20User%20xxx%22.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20question%20is%20if%20the%20(new)%20parameter%20is%20working%20for%20someone%20else%20or%20not%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EKind%20regards%3C%2FP%3E%3CP%3EPatrick%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-216485%22%20slang%3D%22en-US%22%3ERe%3A%20Set-User%20xxx%20-PermanentlyClearPreviousMailboxInfo%20not%20working%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-216485%22%20slang%3D%22en-US%22%3E%3CP%3ECan%20you%20show%20us%20exactly%20what%20you%20are%20seeing%3F%20Also%2C%20open%20a%20support%20case%20and%20report%20it%2C%20it%20doesn't%20seem%20like%20its%20working%20as%20expected%20for%20you...%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi,

regarding that article (https://blogs.technet.microsoft.com/exchange/2018/01/17/permanently-clear-previous-mailbox-info/) the command was introducted to remove mailbox information in office 365 in hybrid scenarios where online mailboxes exist before azure ad connect / exchange hybrid was implemented.

 

Did ever someone used that parameter? I used it and after confirming the deletion it says "completed, but nothing changed" and really nothing happened - the mailbox is still there in EXO?!

 

Has anyone had similar or different experiences with it? Unfortunately, you can only find the articles from the beginning of the year where the parameter was presented.

 

Kind regards

Patrick

3 Replies
Highlighted

Can you show us exactly what you are seeing? Also, open a support case and report it, it doesn't seem like its working as expected for you...

Highlighted

Hi,

I get a feedback like "please confirm... deleting mailbox etc." and when I typ Y, it says "Completed, but nothing changed for User xxx".

 

The question is if the (new) parameter is working for someone else or not :)

 

Kind regards

Patrick

Highlighted
Best Response confirmed by Patrick B (Contributor)
Solution

The solution is to uncheck the EXO license before running the command.