Refine search after semi annual from build 1803 to 1808 on Remote Desktop Server

New Contributor

After the semi annual update from Outlook 365 build 1803 to 1808 we hear from users that the refine search buttons are greyed out. We had this problem earlier when we had the different update plan, So i think that in one of the builds this feature needs something else. 


When going to options in outlook and menu search I can see that I can do a Search Engine Upgrade. However I am unable to install the patch that the link directs me to.


Any thoughts?

8 Replies

Hello @Steven538,

First i suggest to login as administrator in your outlook, then pls. go to your Home Tab - Options. In that Options window select "Search" in left navigation. Next window appears. In bottom left corner there must a hyperlink to start the issue tracking wizzard for the refiners and search tools in Outlook (365/16/19). Check each of the options, if some of the settings for reaching the refiners have changed. Pls. ask your Users, on which refiners (search keywords) they don´t get the result they want to see.

Then: pls check this article on the security updates in Outlook:


Hope that helps. Greets, Eva.



Hi @Eva Vogel,

Thank you for the reply. I do not see a hyperlink to start the issue tracking wizard. 

My search options screen looks like this (see screenshots)

You also see that the refine search options are greyed out.



Hi @Steven538!

Thx for your screenshots!

I think you should click on that button on the top right to upgrade the search, see my screenshot and there is also a button to see the advanced options "Advanced", which indexed sites are relevant to search. If your Search tools are deactivated, you have to define that indexing sites (onenote, onedrive, etc.). Otherwise Outlook doesn´t know where to search on.

Hi @Eva Vogel,

When clicking the link to upgrade my search engine i get redirected to a download site of Microsoft for windows search 4.0 for windows vista. 

When downloading that file and trying to install I get an error (see screenshot).

This function always worked in build 1803. Semi annual update channel had a update last week to build 1808 and since then it doesn't work.

We tried the other update channel last year and we had this same issue, we could then resolve it by reinstalling office with the semi annual update channel.


Hi! OK, now It see!


Search tools with windows Vista in combination where always tricky, that search tool first was designed for Outlook 2010 und Windows 7 and above versions. So you have windows vista for OS... mpfh... According to the security updates in your latest Outlook / Office Update it doesn' t work together anymore. I am so sorry. You have to upgrade at least on Windows 7 or better on Windows 10. Pls check out your upgrade possibilities for your devices like that:

Hi @Eva Vogel,

It is a Terminal server running on Windows Server 2012 r2.

So the reason why it directs me to a windows vista is a mystery to me.

Cannot imagine that this feature would not work anymore for Windows Server 2012 r2. 

On my local laptop i have build 1812 running and there this feature works. (running on windows 10)


Hello! It would be better then to contact microsofts chat, see that link:


Hope that helps. Greets, Eva.