Programmatically adding Signatures to an email

%3CLINGO-SUB%20id%3D%22lingo-sub-1880008%22%20slang%3D%22en-US%22%3EProgrammatically%20adding%20Signatures%20to%20an%20email%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1880008%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20used%20this%20code%20for%20several%20years%20when%20programmatically%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3Ecreating%20emails%20(ii%20Delphi).%3C%2FP%3E%3CP%3EOn%20one%20machine%20Window%2010%2FMicrosoft%20365%20it%20started%20ti%20fail%201%2F3%20weeks%20ago%20(not%20send%20the%20email).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMailItem%3A%20_MailItem%3B%20(from%20Outlook_TLB)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMailItem.GetInspector%3B%3CBR%20%2F%3EMailItem.HTMLBody%20%3A%3D%20Body%20%2B%20MailItem.HTMLBody%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSTRONG%3EError%20Message%26nbsp%3B%3A%20Sorry%2C%20something%20went%20wrong.%20You%20may%20want%20to%20try%20again%3C%2FSTRONG%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20happens%20every%20time%20I%20create%20an%20email%20(not%20on%20my%20Windows%20t%20machine)%20Skipping%20yjis%20code%20sends%20the%20email%20(but%20no%20signature%20-%20which%20we%20need).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20reinstall%20365%20to%20no%20avail.%3C%2FP%3E%3CP%3EWhen%20I%20deleted%20the%20signature%20and%20ran%20the%20code%20it%20also%20errors%20(i.e.%20adding%20a%20null%20signature)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20about%20what%20has%20been%20corrupted%20would%20be%20appreciated.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETIA%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEffy%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1880008%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

I have used this code for several years when programmatically creating emails (ii Delphi).

On one machine Window 10/Microsoft 365 it started ti fail 1/3 weeks ago (not send the email).

 

MailItem: _MailItem; (from Outlook_TLB)

 

 

MailItem.GetInspector;
MailItem.HTMLBody := Body + MailItem.HTMLBody;

 

Error Message : Sorry, something went wrong. You may want to try again

 

This happens every time I create an email (not on my Windows t machine) Skipping yjis code sends the email (but no signature - which we need).

 

I reinstall 365 to no avail.

When I deleted the signature and ran the code it also errors (i.e. adding a null signature)

 

Any ideas about what has been corrupted would be appreciated.

 

TIA

 

Effy

0 Replies