problems with people search (bug?)

%3CLINGO-SUB%20id%3D%22lingo-sub-210227%22%20slang%3D%22en-US%22%3Eproblems%20with%20people%20search%20(bug%3F)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-210227%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20you%20probably%20know%20we%20can%26nbsp%3Bsearch%20person%20by%20last%20name%26nbsp%3Busing%20following%20search%20query%20in%20SharePoint%3A%3C%2FP%3E%3CP%3ELastName%3Aa*.%26nbsp%3B%26nbsp%3BThat's%20all%20good%20and%20well%2C%20right%3F%20Wrong.%26nbsp%3B%20Search%20does%20not%20work%20at%20all.%26nbsp%3B%26nbsp%3BResults%26nbsp%3BI%26nbsp%3B%3CEM%3Eexpect%3C%2FEM%3E%20to%20see%20when%20I%20query%20with%26nbsp%3B%3CSPAN%3E%3CEM%3ELastName%3AA*%3C%2FEM%3E%20(oder%20by%20Lastname)%20would%20be%20something%20like%3A%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EFirstName%2C%20%3CSTRONG%3EAa%3C%2FSTRONG%3E%3B%26nbsp%3B%3CSPAN%3EFirstName%2C%26nbsp%3B%3CSTRONG%3EA%3C%2FSTRONG%3Eb%26nbsp%3BFirstName%2C%26nbsp%3B%3CSTRONG%3EA%3C%2FSTRONG%3Ec%3B%20%3B%20FirstName%2C%26nbsp%3B%3CSTRONG%3EA%3C%2FSTRONG%3Ed.%26nbsp%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EProblematic%20results%26nbsp%3BI%26nbsp%3B%3CEM%3Eactually%3C%2FEM%3E%20see%3A%26nbsp%3B%26nbsp%3B%3CSPAN%3EFirst%20Name%2C%26nbsp%3B%3C%2FSPAN%3E%3CSTRONG%3EAa%3C%2FSTRONG%3E%3CSPAN%3E%3B%26nbsp%3B%3C%2FSPAN%3E%3CSPAN%3EFirst%20Name%2C%26nbsp%3B%3CSTRONG%3EA%3C%2FSTRONG%3Eb%20***%3CEM%3EFirst%20Name%2C%26nbsp%3BB%3CSTRONG%3Ea**%3C%2FSTRONG%3E%3C%2FEM%3E%3B%26nbsp%3B%3B%26nbsp%3BFirst%20Name%2C%26nbsp%3B%3CSTRONG%3EA%3C%2FSTRONG%3Ed%2CFirst%20Name%2C%26nbsp%3B%3CEM%3E%C3%84b%3C%2FEM%3E.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20we%20have%26nbsp%3Bthree%20problems.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFist%20problem%3A%20Search%20returns%20unwanted%20items.%20result%20%22%3CEM%3EFirst%20Name%2C%26nbsp%3BB%3CSTRONG%3Ea%3C%2FSTRONG%3E%22%3CSTRONG%3E%26nbsp%3B%3C%2FSTRONG%3E%3C%2FEM%3Eshould%20not%20be%20returned%20because%20I%20query%20users%26nbsp%3Bwhose%20last%20name%20start%20with%20letter%20%22A%22.%20Search%20actually%20returns%20few%20users%26nbsp%3Bwhose%20last%20name%20or%20first%20name%26nbsp%3Bcontains%20character%20a.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESecond%20problem%3A%26nbsp%3B%26nbsp%3B%3CSPAN%3E%26nbsp%3BSearch%26nbsp%3B%20returns%20users%20whose%20last%20name%20start%20with%20non%20English%26nbsp%3Bcharacters%20like%20%C3%85%2C%20%C3%84%2C%20%C3%96.%26nbsp%3B%20Those%20characters%20fill%20be%20mapped%20to%20english%20as%20follows%3A%20%C3%85%20%26gt%3B%20A%2C%20%C3%84%20%26gt%3B%20A%2C%20%C3%96%20%26gt%3B%20O.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThird%20problem%3A%20%22OrderBy%3ALastname%22%20does%20not%20work%20as%20expected.%26nbsp%3B%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIs%20there%20any%20work%20arounds%20%2F%20solutions%20I%20can%20try%3F%26nbsp%3B%26nbsp%3BFor%20me%20this%20seems%20like%20bug.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-210227%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-211037%22%20slang%3D%22en-US%22%3ERe%3A%20problems%20with%20people%20search%20(bug%3F)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-211037%22%20slang%3D%22en-US%22%3Eby%20chance%20do%20you%20query%20rules%20on%20the%20result%20source%20being%20used%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-210959%22%20slang%3D%22en-US%22%3ERe%3A%20problems%20with%20people%20search%20(bug%3F)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-210959%22%20slang%3D%22en-US%22%3E%3CP%3EHi!%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EDo%20you%20put%20your%20query%20in%20the%20searchbox%20of%20a%20site%2C%20the%20enterprise%20search%20center%20or%20are%20you%20calling%20the%20rest%20api%20when%20you%20get%20these%20results%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

As you probably know we can search person by last name using following search query in SharePoint:

LastName:a*.  That's all good and well, right? Wrong.  Search does not work at all.  Results I expect to see when I query with LastName:A* (oder by Lastname) would be something like:  FirstName, AaFirstName, Ab FirstName, Ac; ; FirstName, Ad. 

 

Problematic results I actually see:  First Name, AaFirst Name, Ab ***First Name, Ba**; ; First Name, Ad,First Name, Äb.

 

So we have three problems. 

 

Fist problem: Search returns unwanted items. result "First Name, Ba" should not be returned because I query users whose last name start with letter "A". Search actually returns few users whose last name or first name contains character a. 

 

Second problem:   Search  returns users whose last name start with non English characters like Å, Ä, Ö.  Those characters fill be mapped to english as follows: Å > A, Ä > A, Ö > O.

 

Third problem: "OrderBy:Lastname" does not work as expected.  

 

Is there any work arounds / solutions I can try?  For me this seems like bug.

 

 

 

 

 

 

 

 

2 Replies
Highlighted

Hi!

 

Do you put your query in the searchbox of a site, the enterprise search center or are you calling the rest api when you get these results?

Highlighted
by chance do you query rules on the result source being used?