Policy alert not sending email

%3CLINGO-SUB%20id%3D%22lingo-sub-1794365%22%20slang%3D%22en-US%22%3EPolicy%20alert%20not%20sending%20email%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1794365%22%20slang%3D%22en-US%22%3E%3CP%3EHey%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20created%20a%20policy%20alert%20in%20Security%20%26amp%3B%20Compliance%20center.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20policy%20is%20set%20to%20go%20off%20whenever%20files%20are%20shared%20externally.%20It%20is%20set%20for%20all%20users%20and%20status%20is%20enabled.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%20there%20are%20no%20email%20being%20send%20to%20anyone%2C%20no%20matter%20how%20many%20files%20I%20share%20with%20external%20users.%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I%20am%20wondering%2C%20if%20there%20is%20something%20I%20have%20forgotten%20to%20turn%20on%20somewhere%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-Michael%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20aware%20some%20delay%20should%20be%20expected%2C%20but%20I%20am%20counting%20several%20days%20at%20this%20point%2C%20so%20I%20am%20thinking%20there%20is%20something%20wrong%20somewhere%20else.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1794365%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECompliance%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1796049%22%20slang%3D%22en-US%22%3ERe%3A%20Policy%20alert%20not%20sending%20email%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1796049%22%20slang%3D%22en-US%22%3E%3CP%3ECan%20you%20see%20the%20actual%20events%20being%20generated%20in%20the%20audit%20log%3F%20If%20so%2C%20either%20try%20to%20recreate%20the%20alert%2C%20or%20open%20a%20support%20case%20and%20report%20this%20as%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1798044%22%20slang%3D%22en-US%22%3ERe%3A%20Policy%20alert%20not%20sending%20email%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1798044%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3B%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20audit%20log%20can%20find%20the%20sharing%20events%20yes.%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20audit%20log%20search%20can't%20however%20search%20for%20external%20item%20shares%2C%20so%20I%20can%20only%20find%20these%20events%20when%20searching%20for%20shares%20in%20general.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20policy%20alert%20however%2C%20is%20set%20with%20the%20condition%26nbsp%3B%3CSPAN%3EExternalFileSharing%20acticity%2C%20so%20maybe%20that%20just%20don't%20work%2C%20even%20though%20it%20should.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hey

 

I have created a policy alert in Security & Compliance center. 

The policy is set to go off whenever files are shared externally. It is set for all users and status is enabled. 

 

However there are no email being send to anyone, no matter how many files I share with external users. 

So I am wondering, if there is something I have forgotten to turn on somewhere?

 

Any suggestions?

 

-Michael

 

I am aware some delay should be expected, but I am counting several days at this point, so I am thinking there is something wrong somewhere else.

 

 

2 Replies

Can you see the actual events being generated in the audit log? If so, either try to recreate the alert, or open a support case and report this as issue.

Hi@Vasil Michev ,

 

The audit log can find the sharing events yes. 

The audit log search can't however search for external item shares, so I can only find these events when searching for shares in general.

 

The policy alert however, is set with the condition ExternalFileSharing acticity, so maybe that just don't work, even though it should.