personal.xlsb file not loading when Excel starts up

%3CLINGO-SUB%20id%3D%22lingo-sub-1400489%22%20slang%3D%22en-US%22%3Epersonal.xlsb%20file%20not%20loading%20when%20Excel%20starts%20up%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1400489%22%20slang%3D%22en-US%22%3E%3CP%3EI%20created%20a%20new%20macro%20and%20stored%20it%20in%20the%20personal%20macro%20workbook.%20When%20I%20open%20the%20XLSTART%20folder%20I%20see%20the%20personal.xlsb%20file%20with%20the%20correct%20time%20stamp.%26nbsp%3B%20But%20when%20I%20shut%20down%20excel%20and%20reopen%20it%20the%20personal.xlsb%20does%20not%20load%20and%20so%20when%20I%20go%20to%20run%20a%20macro%20from%20it%20excel%20does%20not%20show%20it%20as%20being%20available.%26nbsp%3B%20If%20I%20shut%20down%20excel%2C%20then%20double%20click%20on%20the%20personal.xlsb%20file%20it%20opens%20excel%20and%20I%20now%20see%20the%20macros.%20So%20what%20has%20me%20stumped%20is%20why%20it%20is%20not%20automatically%20loading%20when%20I%20start%20up%20excel.%20I%20have%20checked%20all%20the%20setting%20and%20all%20macros%20are%20enabled%2C%20etc.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1400489%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Contributor

I created a new macro and stored it in the personal macro workbook. When I open the XLSTART folder I see the personal.xlsb file with the correct time stamp.  But when I shut down excel and reopen it the personal.xlsb does not load and so when I go to run a macro from it excel does not show it as being available.  If I shut down excel, then double click on the personal.xlsb file it opens excel and I now see the macros. So what has me stumped is why it is not automatically loading when I start up excel. I have checked all the setting and all macros are enabled, etc.

1 Reply
Highlighted

Hi @tomrdillon1944 

 

Can you please try doing the following 

1. Back-up your personal macro workbook (PMW)

2. Create the new workbook & make new PMW

3. copy the codes from your back-up PMW and paste into new one.

 

hope this should fix the issue

 

Regards, Faraz Shaikh | MCT, MIE, MOS Master, Excel Expert

If you find the above solution resolved your query don't forget mark as Official Answer to help the other members find it more