Outlook will not run on VPN Split-tunnel after latest update

%3CLINGO-SUB%20id%3D%22lingo-sub-789522%22%20slang%3D%22en-US%22%3EOutlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-789522%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20running%20a%20setup%20where%20we%20use%20windows%207%20pro%20clients%2C%20and%20Sonicwall%20VPN%20-%20using%20VPN%20as%20split%20tunnel%2C%20which%20means%20user%20gets%20internet%20directly%20and%20not%20routed%20through%20VPN%20to%20save%20bandwidth%20-%20this%20works%20and%20has%20always%20worked.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehowever%2C%20after%20lastest%20update%20(version%201907%20build%2011901.20176)%20Outlook%20%22thinks%22%20that%20there%20is%20no%20internet%20connection%20and%20refuses%20to%20launch...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eif%20not%20connected%20to%20VPN%20it%20works%20fine..%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewindows%20reports%20internet%20connection%20on%20the%20local%20connection%2C%20and%20no%20internet%20connection%20on%20the%20VPN%20which%20is%20as%20it%20should%20be...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eis%20there%20any%20solution%20to%20this%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-789522%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-792504%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-792504%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F387811%22%20target%3D%22_blank%22%3E%40diondp%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Have%20you%20verified%20(which%20i%20believe%20you%20have%20already)%20that%20all%20Latest%20IP%20Ranges%20are%20added%20on%20your%20Firewall%20-%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Fenterprise%2Furls-and-ip-address-ranges%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Foffice365%2Fenterprise%2Furls-and-ip-address-ranges%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E2.%26nbsp%3B%20Run%20Outlook%20Connectivity%20Test%20from%20EXRCA.com%20on%20any%20affected%20workstation%20to%20see%20where%20is%20your%20connectivity%20getting%20broken%20in%20establishing%20the%20connection%20to%20Office%20365%20from%20your%20Outlook%20Clients%20on%20the%20VPN%20Connection.%3C%2FP%3E%3CP%3E3.%20Removing%20VPN%20and%20it%20works%20-%20clearly%20confirms%20there%20is%20something%20not%20right%20on%20the%20Firewall%20level.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%20!%3C%2FP%3E%3CP%3EAnkit%20Shukla%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-792511%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-792511%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Ankit...%20I%20will%20try%20the%20suggested%20solutions%2C%20however%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20think%20you%20are%20missing%20the%20point%20where%20it%20is%20split-tunnel%20VPN%2C%20which%20means%20all%20internet%20traffic%20should%20be%20routed%20directly%20by%20the%20local%20connection%20(and%20windows%20says%20Internet%20connection%20by%20the%20local%20WLAN%2C%20and%20for%20the%20VPN%20it%20says%20%22no%20internet%20connection%22%20which%20has%20always%20been%20the%20case...%20and%20it%20has%20always%20worked%20until%20the%20latest%20office%20update%20for%20about%202%20weeks%20ago...%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eif%20i%20was%20routing%20all%20traffic%20through%20VPN%2C%20then%20yes%20it%20would%20be%20that%20the%20firewall%20had%20a%20misconfiguration%20-%20but%20this%20configuration%20of%20the%20firewall%20has%20not%20been%20modified%20for%20about%20a%20year...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Efor%20now%20-%20we%20are%20using%20remote%20desktop%20solution%20instead%2C%20until%20we%20can%20get%20the%20normal%20connection%20working%20with%20outlook%20again...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-792524%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-792524%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F387811%22%20target%3D%22_blank%22%3E%40diondp%3C%2FA%3E%26nbsp%3B%20Agreed%2C%20lets%20try%20with%20updating%20thee%20IP%20address%20Ranges%20and%20Outlook%20Connectivity%20Test%20from%20EXRCA.com%20on%20any%20affected%20workstation.%20Once%20you%20have%20the%20Report%20or%20XML%20ready%2C%20do%20go%20through%20the%20Errors%20and%20see%20where%20is%20the%20connection%20drops.%20!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%20!%3C%2FP%3E%3CP%3EAnkit%20Shukla%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-792667%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-792667%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F156230%22%20target%3D%22_blank%22%3E%40ankit%20shukla%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eok%20i%20have%20some%20more%20details%20now...%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20have%20tried%20replicating%20the%20issue%20with%20another%20PC%20on%20another%20WAN%20(running%20win10)%20this%20one%20has%20no%20problem...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ei%20think%20the%20problem%20for%20the%20client%20in%20question%20is%20isolated%20to%20the%20machine...%20it%20seems%20if%20i%20dont%20use%20split-tunnel%20and%20force%20everything%20through%20the%20VPN%20it%20still%20says%20no%20internet%20connection%2C%20however%20when%20i%20look%20at%20the%20IP%20details%20of%20that%20client%2C%20it%20has%20no%20default%20gateway...%20if%20i%20insert%20this%20manually%20then%20i%20works%20(still%20no%20cigar%20by%20split-tunnel%20though)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eanyways%20i%20think%20the%20network%20connectivity%20of%20the%20machine%20is%20messed%20up%2C%20i%20have%20tried%20reinstalling%20network%20devices%20without%20any%20luck.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ealthough%20all%20test%20from%26nbsp%3B%3CSPAN%3EEXRCA.com%20succeeds%20without%20problems%2C%20outlook%20still%20wount%20connect%20unless%20it%20is%20only%20connected%20to%20the%20clients%20wifi%20and%20nothing%20else...%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Ewierd%20though%20that%20outlook%20wount%20accept%20connection%2C%20even%20though%20there%20is%20%22internet%22%20status%20of%20one%20connection%2C%20but%20perhaps%20it%20looks%20for%20some%20default%20gateway%20setting%20which%20perhaps%20is%20the%20root%20of%20the%20problem.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-794766%22%20slang%3D%22en-US%22%3ERe%3A%20Outlook%20will%20not%20run%20on%20VPN%20Split-tunnel%20after%20latest%20update%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-794766%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F387811%22%20target%3D%22_blank%22%3E%40diondp%3C%2FA%3E%26nbsp%3BAgreed%2C%20Can%20you%20run%20SARA%20and%20let%20it%20auto%20configure%20-%20it%20will%20atleast%20test%20and%20verify%20you%20what%20is%20the%20root%20cause%20.%20Here%20is%20the%20link%20for%20it%20-%20%3CA%20href%3D%22https%3A%2F%2Fdiagnostics.outlook.com%26nbsp%3B%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdiagnostics.outlook.com%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheers%20!%3C%2FP%3E%3CP%3EAnkit%20Shukla%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

We are running a setup where we use windows 7 pro clients, and Sonicwall VPN - using VPN as split tunnel, which means user gets internet directly and not routed through VPN to save bandwidth - this works and has always worked.

 

however, after lastest update (version 1907 build 11901.20176) Outlook "thinks" that there is no internet connection and refuses to launch...

 

if not connected to VPN it works fine..

 

windows reports internet connection on the local connection, and no internet connection on the VPN which is as it should be...

 

is there any solution to this? 

5 Replies
Highlighted

@diondp 

1. Have you verified (which i believe you have already) that all Latest IP Ranges are added on your Firewall - https://docs.microsoft.com/en-us/office365/enterprise/urls-and-ip-address-ranges 

2.  Run Outlook Connectivity Test from EXRCA.com on any affected workstation to see where is your connectivity getting broken in establishing the connection to Office 365 from your Outlook Clients on the VPN Connection.

3. Removing VPN and it works - clearly confirms there is something not right on the Firewall level.

 

Cheers !

Ankit Shukla

 

Highlighted

Hi Ankit... I will try the suggested solutions, however

 

I think you are missing the point where it is split-tunnel VPN, which means all internet traffic should be routed directly by the local connection (and windows says Internet connection by the local WLAN, and for the VPN it says "no internet connection" which has always been the case... and it has always worked until the latest office update for about 2 weeks ago... 

 

if i was routing all traffic through VPN, then yes it would be that the firewall had a misconfiguration - but this configuration of the firewall has not been modified for about a year...

 

for now - we are using remote desktop solution instead, until we can get the normal connection working with outlook again...

Highlighted

@diondp  Agreed, lets try with updating thee IP address Ranges and Outlook Connectivity Test from EXRCA.com on any affected workstation. Once you have the Report or XML ready, do go through the Errors and see where is the connection drops. !

 

Cheers !

Ankit Shukla

 

Highlighted

@ankit shukla 

 

ok i have some more details now... 

i have tried replicating the issue with another PC on another WAN (running win10) this one has no problem...

 

i think the problem for the client in question is isolated to the machine... it seems if i dont use split-tunnel and force everything through the VPN it still says no internet connection, however when i look at the IP details of that client, it has no default gateway... if i insert this manually then i works (still no cigar by split-tunnel though)

 

anyways i think the network connectivity of the machine is messed up, i have tried reinstalling network devices without any luck.

 

although all test from EXRCA.com succeeds without problems, outlook still wount connect unless it is only connected to the clients wifi and nothing else...

 

wierd though that outlook wount accept connection, even though there is "internet" status of one connection, but perhaps it looks for some default gateway setting which perhaps is the root of the problem.

 

Highlighted

@diondp Agreed, Can you run SARA and let it auto configure - it will atleast test and verify you what is the root cause . Here is the link for it - https://diagnostics.outlook.com 

 

Cheers !

Ankit Shukla