Opening Visual Basic crashes Microsoft Access

%3CLINGO-SUB%20id%3D%22lingo-sub-1462639%22%20slang%3D%22en-US%22%3EOpening%20Visual%20Basic%20crashes%20Microsoft%20Access%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1462639%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Microsoft%20Community.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20currently%20experiencing%20problems%20with%20Access%20crashing%20as%20I%20try%20to%20view%20some%20code%20via%20Visual%20Basic.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20was%20made%20by%20a%20colleague%20and%20wanted%20me%20to%20test%20it%20out%2C%20but%20Access%20keeps%20crashing%20and%20restarts%20every%20time%20I%20tried%20to%20access%20a%20specific%20user-written%20function's%20code.%20I%20tried%20just%20opening%20visual%20basic%20and%20opening%20any%20of%20the%20forms%20via%20project%20explorer%20to%20find%20if%20there%20was%20any%20offending%20code%2C%20but%20the%20window%20also%20doesn't%20show%20any%20code.%20The%20directory%20indicates%20that%20I'm%20supposedly%20viewing%20the%20file%2C%20but%20all%20I%20get%20is%20a%20blank%20window%2C%20unable%20to%20press%20any%20buttons.%20Since%20this%20is%20a%20work%20computer%20with%20limited%20permissions%2C%20I%20haven't%20had%20the%20opportunity%20to%20reinstall%20Office%20365.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20tried%20to%20open%2Ftest%20the%20code%20on%20a%20machine%20separate%20to%20mine%20and%20my%20colleague's%20and%20it%20worked%20with%20zero%20problems.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20tried%20starting%20from%20a%20blank%20database%20and%20opening%20visual%20basic%20through%20that%20file%20and%20there%20has%20been%20no%20problems%20like%20crashing%20or%20blank%20windows.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20it%20helps%2C%20the%20code%20was%20written%20with%20some%20Japanese%20characters%20in%20it%20(I%20assume%20the%20functions%20used%20are%20still%20in%20English%20but%20some%20strings%20are%20in%20Japanese)%2C%20but%20seeing%20that%20I'm%20also%20using%20office%20with%20a%20Japanese%20language%20pack%20(on%20a%20computer%20with%20Japanese%20Windows%2010)%20it%20comes%20across%20as%20it%20might%20be%20software%20issue%2C%20possibly%20even%20a%20hardware%20issue.%20I%20tried%20resetting%20the%20PC's%20language%20to%20Japanese%20to%20address%20the%20language%20problem%20and%20even%20that%20didn't%20work%20out.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20anyone%20has%20any%20insight%2F%20suggestions%20on%20what%20to%20do%20that'd%20be%20greatly%20appreciated!%20Thank%20you%20in%20advance.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1462639%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20Apps%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Established Member

Hello Microsoft Community.

 

I'm currently experiencing problems with Access crashing as I try to view some code via Visual Basic.

 

It was made by a colleague and wanted me to test it out, but Access keeps crashing and restarts every time I tried to access a specific user-written function's code. I tried just opening visual basic and opening any of the forms via project explorer to find if there was any offending code, but the window also doesn't show any code. The directory indicates that I'm supposedly viewing the file, but all I get is a blank window, unable to press any buttons. Since this is a work computer with limited permissions, I haven't had the opportunity to reinstall Office 365.

 

We tried to open/test the code on a machine separate to mine and my colleague's and it worked with zero problems.

 

I tried starting from a blank database and opening visual basic through that file and there has been no problems like crashing or blank windows.

 

If it helps, the code was written with some Japanese characters in it (I assume the functions used are still in English but some strings are in Japanese), but seeing that I'm also using office with a Japanese language pack (on a computer with Japanese Windows 10) it comes across as it might be software issue, possibly even a hardware issue. I tried resetting the PC's language to Japanese to address the language problem and even that didn't work out.

 

 

If anyone has any insight/ suggestions on what to do that'd be greatly appreciated! Thank you in advance.

0 Replies