Office 365 Group did not created SharePoint ?

Valued Contributor

Hi Community Members,


Recently I created an office 365 group from Admin Center > Exchange > Groups the O365 group created with all the standard setting we wanted, went to Teams Interface so can enabled the Teams for it which is done too, but when I try to check the Wiki page in Teams or the File tab it is showing me message "we are setting up your file directory" when I check the SharePoint section of it says the 404 files not found.

See the attached files for more details I did wait for 2 days and today posting it.

files tab.PNG


9 Replies
Seems something went wrong during provisioning of the group! I would create a ticket with MS or just delete it and create a new group instead! Or keep it and do both :)


Hi @PDostiyar 


We are having the same issue and the Office 365 support couldn't yet help me.

Did you find a solution on your tenant?



@gstettlerthe only quick solution for this was to delete the groups which was a new group and then waited for the sync and recreated the with the same name and details and this time it worked.

@PDostiyar so your groups were all synced with AAD Connect?

sometimes it also happens with any new channels created within Teams so the solution is the same rename the channel, then delete it, recreates and it will work fine.


why renew the channel so that you could have the same name available for use.

Strange.. just tried this but it doesn't work on our tenant.

even the delete option did not work then i would suggest optioning a ticket with Microsoft @gstettler 


I Had the same problem, found a Fix somewhere else:


if i open this link for each O365 Group i created it generated a Sharepoint site:

i found the link in the "You've joined the GROUP_NAME group" mail sent to members, in the sharepoint section.
after clicking the Link it generated the pages without a problem.

Hope this helps

@Claudio_Chcorrect you are totally right but that is not the case with me, the link was already clicked and I did tried other options but still got this issue which happens somtimes....