Office 365 Email Encryption OME

I would like to implement OME within my organization. At initial glance, it seems to work great with the one time passcode approach. However I have noticed that if the recipient doesn't check the box to remember the passcode for 12 hours any subsequent response received result in a "Authentication did not complete message". I have scoured the internet and there doesn't seem to be a setting to force the check box to be checked. The only way I see around this is to clear out the cookies for Does anyone have any suggestions on how to make this work correctly or can recommend a different approach? Thanks.
18 Replies

@Chris_Mancini Hi, would you mind elaborate on the post? You mean that if just using the default setting (15 min limit on the OTP) and not checking the "this is a private computer" the users receive the message? Even though the OTP is used within the 15 minutes?

@ChristianBergstrom Yes, default setting. I send an email from Outlook to a test gmail account and choose Encrypt-Only. In the Gmail account I receive the email that says "Read Secure Message". I am taken to a page that says "Sign in with one time passcode". I click to receive the passcode and it is sent to the test gmail account. I am taken to a screen to input the passcode. There is the "This is a private computer..." checkbox. If I don't check it, then subsequent encrypted responses or new messages to the gmail account are sent to the account. However, when I click "Read Secure Message" I receive a page with "Authentication did not complete". If I check the "This is a private computer..." then everything works fine. Thanks for your help.


@Chris_Mancini Hi, I had to verify this so created a Gmail account and sent an OME "encrypt only" to the address. OTP was selected and a new code is always being used when replying or sending new emails to the Gmail address. I did not check the box to "remember this device for 12 hours" and am able to enter a new OTP code several times, that is for every new message and new replies as well. In other words I cannot reproduce your issue. I suppose it's browser related and the check box "workaround" you are using also suggests this. Have you tried using different browsers or maybe verify what differentiates your browser settings from default settings for example? Perhaps check with your own org. if you have several units managing applications (the browser).

@ChristianBergstrom Good advice...I have been using Chrome on my company laptop and I tried MS Edge on the same device and experienced the same behavior. However, when I test with my personal Macbook with Chrome it functions flawlessly so it appears it may be an internal browser setting. I have no idea what setting may be causing this but it helps point me in the right direction. Do you use OME consistently and, if so, have you had any issues with encryption outside of your org?

@Chris_Mancini Hello, even though it has been around for years there has been a stalemate in our org. due to legal technicalities (such as the key). This has progressed lately and now I'm involved in a pre-study as how OME actually behaves when using the "encrypt-only" template with and without attachments that are being replied to, as well as forwarded to internal/external individuals as second, third and forth recipient. One might think this should be pretty straightforward (and it is when only the sender and the initial recipients is involved to answer your question) but it's getting a bit complex when adding the others. This is not a common scenario and the unit in need of the encryption has a flow that is difficult to explain. So we'll see if they can use OME or if we need to look at another solution.


In short. OME is great and easy to use for all users in an org. but if you're looking at it from a "encryption point of view" you could say it's not "asymmetric" but rather a "symmetric" solution which is much easier to manage and use.

@ChristianBergstrom Gotcha, we have taken a look at our settings and can't figure out what is causing our original issue. If you or someone else has any further input it would be great. Thanks for your help

@Chris_Mancini I have to ask what settings have you looked at? Should be something with the cookies/session as it only works when checking the box to be remembered.

@ChristianBergstrom So we did some further testing with home computers that aren't connected to our organization and had the same failure...these were Windows machines. So I am at a loss unless there are other ideas floating out there.

I'd like to hop on this thread and say that my organization is also seeing these issues. I have tested this myself by sending to a Gmail and I receive the same error. I do have an attached file. This is making things hard for our users because they're having to resend their emails when the recipient doesn't save the attachment.

@akeinath I knew this wasn't an isolated issue as I have seen this from other organizations. This company has even written up a troubleshooting section on their site for their clients.


Do the proposed workaround solve the issue for you as well then? (using InPrivate / Incognito windows).

I am not able to reproduce the authentication message.

@ChristianBergstrom If I use Incognito then it will do it again until I close the incognito window and re-open it. That makes sense if the issue is with cookies. I'm using the new Edge browser.


The email I'm sending is from my Exchange account to a Gmail account with a PDF attached to it. The users that reported it to me were also trying to attach and send to outside addresses.

Seems very inconsistent when reading your replies. Perhaps you need to open up support tickets with Microsoft to get a proper analyze/answer of what’s going on.

Btw, you’ve enabled the pdf encryption in the IRM configuration? (not set to true by default).
Users have been sending PDFs this way for years. I doubt that it's related to a setting.

And the issue is consistent. If I open Incognito, it works the first time and then stops working. If I close that Incognito window and open another (starting a new session) it works again one time and then stops. The issue is with the cookies.

I have submitted feedback on the issue and I am going to try to open a support ticket when I have the chance.

@akeinath I agree...this issue seems to be a Microsoft issue. We have our tenant managed by Rackspace. I contacted them with the same scenario and they were able to replicate the "Authentication could not complete" issue. I am trying to work this through them with Microsoft.

Well, how could I possibly know that? Just wanted to put it out there as the Outlook client (desktop) itself cannot encrypt PDF so has to be done backend.

As for the inconsistency part I got the impression you two did not have identical issues, obviously you do. We (my org.) do not experience that same issue, cannot reproduce it either, so it sounds good that you’re going to open tickets with the official support.

Please update this conversation when they reply with an solution.
Hello! Did Microsoft find a solution to your issue?