Office 365 Admin Centers Slow

Contributor

Why are the Office 365/Azure admin centers so slow? I find with tenants hosted in all sorts of regions (EMEA, Australia, US) that general navigation and operation within the admin centers is slow. This is irrespective of my internet connection, client machine, browser, etc. The common denominator is Office 365/Azure. 

 

CDN material (images, css) seem to load just fine, but the actual data is slow as anything.

 

Is this a widespread issue for others?

18 Replies
I'm not seeing a particular difference in response times compared with other days...and in Office 365 the health dashboard is not showing an error message related to the Office 365 Portal
Sorry, I probably wasn't clear. I should've added "Always". Every day of my life this is a problem, it's never faster than "slow", but occasionally approaches "extremely slow".

It is the same for me and my co-workers Chris when accessing the office365 admin.  Was much quicker to respond a few months back and since then it takes forever to do things.  Trying to add someone to a shared mailbox today took 5 minutes waiting for the information to load on the page.

For us its not just the Admin panel but also Exchange and Sharepoint very very slow response, to every query a user profile very slow. MS please fix this issue, maybe add more resources to your hosting. 

Well, I'm seeing there are three incidents Today in the Health dashboard that are related to EXO, SPO and ODFB that could be the cause of this slowness when accessing to the services...in regards of the Admin Center performance is fine to me

It could have been internet issue initially but as you said it has nothing to do with internet, i am not sure what might be causing that. Have you opened a case in the support for Microsoft?

 

I have been using Office 365 for an year, and i have not faced such laziness in Admin Center.


@Chris Brown wrote:

 

Is this a widespread issue for others?


Yes. Slow admin portals is the norm. O365, EXO, OneDrive, Azure...

 

Quite a lot of my readers complain to me about it. Obviously there's nothing I can do to help them with that.

I'm glad you're seeing chatter about it too - I thought I was going crazy! Don't know who or how to poke at Microsoft to talk to someone about this. I'm guessing that the normal support channels are just going to shrug me off.
Here also slow !

Did you jiggle the cable?

 

Edited to add:

The portals really seem like the weakest link in the Office 365 Microsoft chain. There's something quite ironic about 'upgrading' my browser to IE from Edge every time I want to administer Intune.

I've always found the O365 admin centers very variable. I came to this thread because this morning they've been driving me up the wall (1 minute + page refresh times, intermittent errors moving between pages etc). But in the time it's taken to register my account to comment here it's suddenly come good. (Yes, I checked that my internet link wasn't being hammered while I was experiencing slowness at O365: the rest of the internet was just fine thank you very much - even the very latency-sensitive AJAXey parts of the internet).

 

Slowness in the O365 admin centers seems to be an ongoing problem though.

 

On a similar note, Microsoft's various federated sign ins have been historically awful (I must say that I was pleasantly surprised today when I logged in. It's been around four months since I last signed in anywhere at Microsoft and I'm seeing "new signin experience" banners everywhere. In the past I've torn my hair out on numerous occasions signing in with passport to log in to the microsoft partner center (I always cross my fingers when I see /adfs flash up in a URL moving between Microsoft sites).

 

Plus, there's too much sharepoint involved in Microsoft's systems. Anything that sharepoint powers is bound to be slow, clunky and generally hateful.

 

I almost never have these problems with similar sized systems at google or amazon.

 

Anyway, fingers crossed whatever Microsoft has done to their sign-in seems to have sorted out the old active directory federated services nightmare.

 

/end rant

We are experiencing the same sluggish admin interfaces here. It has been the case for the entire year we've been using o365, across multiple machines and with a fast net connection. It must be pretty embarrassing to be a major cloud provider who doesn't have the infrastructure to provide even an acceptable user experience to admins. I imagine it's also a huge disincentive for partners and service resellers as they're the ones who will receive the support calls but will not be able to take any action. At the moment this issue is preventing us from expanding into o365; we're staying on prem until it's sorted or we find a decent competitor.

Over the past few months, my team and I have noticed particularly sluggish performance as follows:

Log in to O365

Click the apps menu

Select Partner

Click "clients" to expand the list of clients (reference link: https://portal.office.com/Partner/ModernShell.aspx#ClientListView )

* Here is where the issue happens: When we click the little link for the O365 Admin Center for a client, we might have to wait a minute or more for the page to load. We can close the new window, click the link again, get a new window and still wait for more than a minute... Pretty frustrating when you're trying to knock things out on the fly!

I'm mostly experienced with the Exchange admin center. It is incredibly slow. Almost useless as this wastes a lot of time.

You are better than that!  Waive that magic wand!  JK JK  I have noticed over the last few years any dynamic content within the portals are getting brutally slow...

 

Regardless, your articles are great, have helped me in many situations, thanks for all your contributions!

Not enough noise of this matter...
office 365 admin portal is always slow, but sometimes it is frustrating to use! when it happens all our IT guys experience this while our internet connection is perfectly fine.

Why are google services always so smooth in comparison? (ok gmail was rubbish for a few days after update)

@Chris Brown  I have always noticed it being slow, and it gets slower the more activity you do.

 

When off boarding several users, I need to convert mailboxes to shared, rename them, change the email address and user information, then remove the licenses.  After each user, the response time reduces, until it's so slow that I have to wait 10-15 seconds between actions for the page to be ready for input.

 

I have never had this not happen, admin console has always been slow after working in it for even 5-10 minutes.

I am having the same issue using IE 11 I can click on Users - Active users and do a search and watch the name fill in one letter at a time. If I use chrome I have no issues, loads fast no lag. It figures Microsoft portal works better with Google Chrome hmmm.

 

KZ