Network Import PST to Exchange Online- Subfolder not created

%3CLINGO-SUB%20id%3D%22lingo-sub-264812%22%20slang%3D%22en-US%22%3ENetwork%20Import%20PST%20to%20Exchange%20Online-%20Subfolder%20not%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-264812%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EHello!%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWe%20have%20an%20Exchange%20Online%20system.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWe%20would%20like%20to%20Import%20our%20old%20PSTs%20using%20the%20Network%20import%20method%20though%20the%20Admin%20portal.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EWe%20use%20the%20AZCOPY%20program%20and%20the%20format%20of%20the%20import%20is%20below.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ENote%20the%20addition%20of%20the%20extra%20path%20for%20the%20BLOB%20%22%3CSTRONG%3E%3CSPAN%3E%2F%3CSPAN%3Eingestiondata%2FPSTFiles%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FSTRONG%3E%22%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThat%20should%20create%20a%20subfolder%20under%20the%20blob%20with%20the%20PST%20file%20%3CSTRONG%3E%3CSPAN%3Eusername.pst%3C%2FSPAN%3E%3C%2FSTRONG%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Ecommand%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Eazcopy%20%2FSource%3A%5C%5CUNC-path%5COutlook-Archive%5C%3CSTRONG%3E%3CSPAN%3Eusername.pst%3C%2FSPAN%3E%3C%2FSTRONG%3E%2FDest%3A%22%3CA%20href%3D%22https%3A%2F%2F11111.blob.core.windows.net%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CSPAN%3Ehttps%3A%2F%2F11111.blob.core.windows.net%3C%2FSPAN%3E%3C%2FA%3E%3CSTRONG%3E%3CSPAN%3E%2Fingestiondata%2FPSTFiles%3C%2FSPAN%3E%3C%2FSTRONG%3E%3Fsv%3D2018-04-05%26amp%3Bsr%3Dc%26amp%3Bsi%3DIngestionSasForAzCopy20180925%26amp%3Bsig%3D*****%26amp%3Bse%3D2018-10-31T01%253A16%253B05Z%22%20%2FV%3Ac%3A%5Ctemp%5Cupload.txt%20%2FY%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EAccording%20to%20the%20documentation%2C%20this%20should%20work%2C%20however%20%3CSPAN%3Eafter%20import%20the%20PST%20file%20is%20not%20called%26nbsp%3B%3CSTRONG%3E%3CSPAN%3Eingestiondata%2FPSTFiles%2F%3C%2FSPAN%3Eusername.pst%3C%2FSTRONG%3E%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3Bbut%26nbsp%3B%3CSTRONG%3E%3CSPAN%3Eingestiondata%2F%3C%2FSPAN%3EPSTFILES%3C%2FSTRONG%3E%3C%2FSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3ENote%20that%20if%20I%20do%20not%20add%20the%20PSTFiles%20into%20the%20Dest%20field%20then%20the%20AZCOPY%20fails%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EAm%20I%20missing%20something%20with%20the%20copy%20system%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Ethanks%2C%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Eadrian%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-264812%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-266606%22%20slang%3D%22en-US%22%3ERe%3A%20Network%20Import%20PST%20to%20Exchange%20Online-%20Subfolder%20not%20created%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-266606%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3E%3CBR%20%2F%3EAnyone%20else%20seen%20this%20behaviour%3F%3CBR%20%2F%3E%3CBR%20%2F%3Echeers%2C%3CBR%20%2F%3Eadrian%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hello!

 

We have an Exchange Online system.

We would like to Import our old PSTs using the Network import method though the Admin portal.

 

We use the AZCOPY program and the format of the import is below.

Note the addition of the extra path for the BLOB "/ingestiondata/PSTFiles"

That should create a subfolder under the blob with the PST file username.pst

 

 

command:

azcopy /Source:\\UNC-path\Outlook-Archive\username.pst /Dest:"https://11111.blob.core.windows.net/ingestiondata/PSTFiles?sv=2018-04-05&sr=c&si=IngestionSasForAzCopy20180925&sig=*****&se=2018-10-31T01%3A16%3B05Z" /V:c:\temp\upload.txt /Y

 

According to the documentation, this should work, however after import the PST file is not called ingestiondata/PSTFiles/username.pst but ingestiondata/PSTFILES 

 

Note that if I do not add the PSTFiles into the Dest field then the AZCOPY fails

 

Am I missing something with the copy system?

 

thanks, 

adrian

 

1 Reply
Highlighted
Hi,

Anyone else seen this behaviour?

cheers,
adrian