MRS Proxy

%3CLINGO-SUB%20id%3D%22lingo-sub-1996871%22%20slang%3D%22en-US%22%3EMRS%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1996871%22%20slang%3D%22en-US%22%3E%3CP%3EGoodmorning%20everyone%2C%3CBR%20%2F%3Ein%20my%20company%20we%20have%20two%20exchanges%20(one%202016%20and%20one%202019)%20configured%20in%20hybid%20mode%20with%20Office365.%3CBR%20%2F%3EEverything%20works%20correctly%20and%20without%20problems%2C%20the%20only%20problem%20I%20encounter%20is%20that%20when%20I%20turn%20off%20the%20Exchange%202016%20and%20try%20to%20migrate%20an%20ExchangeOnLine%20mailbox%20from%20Office365%20the%20new%20migration%20batch%20gives%20me%20this%20error%3A%3C%2FP%3E%3CP%3Eerror%3CBR%20%2F%3EThe%20connection%20to%20the%20server%20'mail.namecorporation.it'%20could%20not%20be%20completed.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%2C%20i%20poweron%20the%20exchange%202016%2C%20everything%20returns%20to%20work%20correctly.%20On%20virtual%20directories%20on%20both%20roles%20EWS%20is%20set%20with%20%22Enable%20MRS%20proxy%20endpoint%22.%3C%2FP%3E%3CP%3EAt%20the%20network%20level%20I%20have%20checked%20and%20everything%20seems%20ok%20with%20regards%20to%20pointing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20wondering%20if%20there%20was%20some%20sort%20of%20priority%20within%20the%20exchange%20organization%20between%20the%20two%20servers%20for%20managing%20the%20migration%20of%20the%20online%20mailbox%2C%20and%20if%20there%20was%20where%20can%20I%20find%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20does%20anyone%20know%20the%20type%20of%20HTTPS%20string%20that%20arrives%20as%20a%20request%20from%20Office365%20to%20Exchange%3F%20For%20example%2C%20when%20calling%20OWA%20the%20string%20is%20of%20this%20type%20%3CA%20href%3D%22https%3A%2F%2Fmail.company.it%2Fowa%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmail.company.it%2Fowa%3C%2FA%3E%2C%20when%20calling%20EWS%20same%20URL%20but%20ending%20with%20EWS.%3C%2FP%3E%3CP%3ESince%20I%20saw%20that%20it%20uses%20EWS%20to%20manage%20the%20migration%20I%20was%20wondering%20how%20the%20request%20was%20written.%3CBR%20%2F%3EThanks%20in%20advance%20for%20the%20help%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%3CBR%20%2F%3EAngelo%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1996871%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ehybrid%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1996891%22%20slang%3D%22en-US%22%3ERe%3A%20MRS%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1996891%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F904919%22%20target%3D%22_blank%22%3E%40angeloforum%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EWhen%20you%20enable%20MRSProxy%20on%20servers%20you%20will%20need%20to%20do%20IISReset%20on%20those%20servers%20to%20fully%20enable%20them.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECan%20you%20do%20IISReset%20on%20other%20servers%20%3F%20Are%20all%20services%20pointing%20to%202019%20%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%20Regards%2C%3CBR%20%2F%3ENuno%20%C3%81rias%20Silva%3CBR%20%2F%3EOffice%20Apps%20and%20Services%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.nuno-silva.net%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.nuno-silva.net%3C%2FA%3E%3CBR%20%2F%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2002334%22%20slang%3D%22en-US%22%3ERe%3A%20MRS%20Proxy%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2002334%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F904919%22%20target%3D%22_blank%22%3E%40angeloforum%3C%2FA%3E%2C%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegarding%20the%20error%20that%20you%20are%20facing%20may%20be%20some%20permissions%20or%20problems%20on%20Autodiscover.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EEnable%20the%20MRSProxy%20and%20set%20the%20authentication%20required%20to%20perform%20the%20move.%20To%20do%20this%2C%20run%20the%20following%20cmdlet%3A%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3ESet-WebServicesVirtualDirectory%20-Identity%20%22Server%5CEWS%20(default%20Web%20site)%22%20%E2%80%93MRSProxyEnabled%20%24true%20%E2%80%93%20WSSecurityAuthentication%20%24True%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ECan%20you%20see%20this%20post%20if%20it%20resolves%20the%20problem%3F%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Foffice-365%2Funable-to-configure-migration-endpoint-hybrid-exchange%2Fm-p%2F94111%22%20target%3D%22_blank%22%20rel%3D%22noopener%22%3EUnable%20to%20configure%20migration%20Endpoint%20-%20Hybrid%20Exchange%20-%20Microsoft%20Tech%20Community%3C%2FA%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EBest%20Regards%2C%3CBR%20%2F%3ENuno%20%C3%81rias%20Silva%3CBR%20%2F%3EOffice%20Apps%20and%20Services%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fwww.nuno-silva.net%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.nuno-silva.net%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Goodmorning everyone,
in my company we have two exchanges (one 2016 and one 2019) configured in hybid mode with Office365.
Everything works correctly and without problems, the only problem I encounter is that when I turn off the Exchange 2016 and try to migrate an ExchangeOnLine mailbox from Office365 the new migration batch gives me this error:

error
The connection to the server 'mail.namecorporation.it' could not be completed.

 

If, i poweron the exchange 2016, everything returns to work correctly. On virtual directories on both roles EWS is set with "Enable MRS proxy endpoint".

At the network level I have checked and everything seems ok with regards to pointing.

 

I was wondering if there was some sort of priority within the exchange organization between the two servers for managing the migration of the online mailbox, and if there was where can I find it?

 

Also does anyone know the type of HTTPS string that arrives as a request from Office365 to Exchange? For example, when calling OWA the string is of this type https://mail.company.it/owa, when calling EWS same URL but ending with EWS.

Since I saw that it uses EWS to manage the migration I was wondering how the request was written.
Thanks in advance for the help

 

Regards
Angelo

5 Replies

Hi @angeloforum,

 

When you enable MRSProxy on servers you will need to do IISReset on those servers to fully enable them.

 

Can you do IISReset on other servers ? Are all services pointing to 2019 ?

 

Best Regards,
Nuno Árias Silva
Office Apps and Services
https://www.nuno-silva.net
 

Hi @Nuno Silva,

yes i have restart iis but nothing change.

Yes all service point new server exchange 2019.

 

Hi have try this test in PS:

Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress angelotest4@mycompany.it

 

this is the output:

PS C:\> Test-MigrationServerAvailability -ExchangeRemoteMove -Autodiscover -EmailAddress angelotest4@mycompany.it
Richiesta credenziali di Windows PowerShell: cmdlet Test-MigrationServerAvailability at command pipeline position 1
Avviso: uno script o un'applicazione nel computer remoto OUTLOOK.OFFICE365.COM ha richiesto le credenziali dell'utente.
Immettere le credenziali solo se si considerano attendibili il computer remoto e l'applicazione o lo script che le
richiede.

Supply values for the following parameters:
Credentials


RunspaceId : f94047a5-e3b6-4315-80a8-5f048583a837
Result : Failed
Message : The ExchangeRemote endpoint settings could not be determined from the autodiscover response. No
MRSProxy was found running at 'mail.mycompany.it'.
SupportsCutover : False
ErrorDetail : internal
error:Microsoft.Exchange.Migration.MigrationRemoteEndpointSettingsCouldNotBeAutodiscoveredException:
Non sono riuscito a stabilire le impostazioni dell'endpoint ExchangeRemote dalla risposta
dell'individuazione automatica. Non ci sono MRSProxy in esecuzione su 'mail.mycompany.it'. --->
Microsoft.Exchange.Migration.MigrationServerConnectionFailedException: Non sono riuscito a
completare la connessione al server 'mail.mycompany.it'. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemoteTransientException: La chiamata a
'https://mail.mycompany.it/EWS/mrsproxy.svc' non è riuscita. Dettagli errore: The underlying connection
was closed: A connection that was expected to be kept alive was closed by the server. --> The
underlying connection was closed: A connection that was expected to be kept alive was closed by the
server. --> Unable to read data from the transport connection: A connection attempt failed because
the connected party did not properly respond after a period of time, or established connection
failed because connected host has failed to respond. --> A connection attempt failed because the
connected party did not properly respond after a period of time, or established connection failed
because connected host has failed to respond. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemotePermanentException: The underlying connection
was closed: A connection that was expected to be kept alive was closed by the server. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemotePermanentException: The underlying connection
was closed: A connection that was expected to be kept alive was closed by the server. --->
Microsoft.Exchange.MailboxReplicationService.MRSRemotePermanentException: Unable to read data from
the transport connection: A connection attempt failed because the connected party did not properly
respond after a period of time, or established connection failed because connected host has failed
to respond. ---> Microsoft.Exchange.MailboxReplicationService.MRSRemotePermanentException: A
connection attempt failed because the connected party did not properly respond after a period of
time, or established connection failed because connected host has failed to respond
--- End of inner exception stack trace ---
--- End of inner exception stack trace ---
--- End of inner exception stack trace ---
--- End of inner exception stack trace ---
at Microsoft.Exchange.MailboxReplicationService.MailboxReplicationServiceFault.ReconstructAndThrow
(String serverName, VersionInformation serverVersion)
at Microsoft.Exchange.Connections.Common.WcfClientWithFaultHandling`2.<>c__DisplayClass4_0.<CallSe
rvice>b__0()
at Microsoft.Exchange.Net.WcfClientBase`1.CallService(Action serviceCall, String context)
at Microsoft.Exchange.Connections.Common.WcfClientWithFaultHandling`2.CallService(Action
serviceCall, String context)
at Microsoft.Exchange.MailboxReplicationService.WcfClientWithVersion`2.CallService(Action
serviceCall, String context)
at Microsoft.Exchange.Migration.MigrationExchangeProxyRpcClient.CanConnectToMrsProxy(Fqdn
serverName, Guid mbxGuid, NetworkCredential credentials, LocalizedException& error)
--- End of inner exception stack trace ---
at
Microsoft.Exchange.Migration.MigrationEndpointVerifier.VerifyConnectivity(MigrationEndpointBase
endpoint)
at Microsoft.Exchange.Management.Migration.MigrationService.Endpoint.TestMigrationServerAvailabili
ty.InternalProcessEndpoint(Boolean fromAutoDiscover)
--- End of inner exception stack trace ---
TestedEndpoint :
IsValid : True
Identity :
ObjectState : New

 

Regards

Angelo

Hi @angeloforum,

 

Regarding the error that you are facing may be some permissions or problems on Autodiscover.

 

Enable the MRSProxy and set the authentication required to perform the move. To do this, run the following cmdlet:
Set-WebServicesVirtualDirectory -Identity "Server\EWS (default Web site)" –MRSProxyEnabled $true – WSSecurityAuthentication $True

 

Can you see this post if it resolves the problem?

 

Unable to configure migration Endpoint - Hybrid Exchange - Microsoft Tech Community

 

Best Regards,
Nuno Árias Silva
Office Apps and Services
https://www.nuno-silva.net

Hi @Nuno Silva 

sorry for the delay of my reply

 

This is the poutput of GET command

 

[PS] C:\Windows\system32>Get-WebServicesVirtualDirectory -Server SERVEREXCNAHE |fl


RunspaceId : 0a443cd0-a54a-4d6a-8b88-ccae1d1cdd11
CertificateAuthentication :
InternalNLBBypassUrl :
GzipLevel : Low
MRSProxyEnabled : True
Name : EWS (Default Web Site)
InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}
LiveIdNegotiateAuthentication :
WSSecurityAuthentication : True
LiveIdBasicAuthentication : False
BasicAuthentication : False
DigestAuthentication : False
WindowsAuthentication : True
OAuthAuthentication : True
AdfsAuthentication : False
MetabasePath : IIS://SERVEREXCHANGE.MYCOMPANY.com/W3SVC/1/ROOT/EWS
Path : C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\EWS
ExtendedProtectionTokenChecking : None
ExtendedProtectionFlags : {}
ExtendedProtectionSPNList : {}
AdminDisplayVersion : Version 15.2 (Build 464.5)
Server : SERVEREXCHANGE
InternalUrl : https://mail.MYCOMPANY.it/ews/exchange.asmx
ExternalUrl : https://mail.MYCOMPANY.it/ews/exchange.asmx
AdminDisplayName :
ExchangeVersion : 0.10 (14.0.100.0)
DistinguishedName : CN=EWS (Default Web Site),CN=HTTP,CN=Protocols,CN=SERVEREXCHANGE,CN=Servers,CN=Exchange Administrative Group
(FYDIBOHF23SPDLT),CN=Administrative Groups,CN=Gruppo Zenit,CN=Microsoft
Exchange,CN=Services,CN=Configuration,DC=gruppozenit,DC=com
Identity : SERVEREXCHANGE\EWS (Default Web Site)
Guid : ed902395-5303-4d73-9a10-dfa247f2232f
ObjectCategory : MYCOMPANY.com/Configuration/Schema/ms-Exch-Web-Services-Virtual-Directory
ObjectClass : {top, msExchVirtualDirectory, msExchWebServicesVirtualDirectory}
WhenChanged : 28/11/2019 14:38:37
WhenCreated : 28/11/2019 13:21:58
WhenChangedUTC : 28/11/2019 13:38:37
WhenCreatedUTC : 28/11/2019 12:21:58
OrganizationId :
Id : SERVEREXCHANGE\EWS (Default Web Site)
OriginatingServer : DOMAINCONTROLLER.gruppozenit.com
IsValid : True
ObjectState : Changed

 

 

Hi @angeloforum,

 

The configuration seems correct or some issue that is not explicit. If that command does not resolve the problem, I suggest opening a support ticket.

 

Best Regards,
Nuno Árias Silva
Office Apps and Services
https://www.nuno-silva.net