Message Trace not working

Occasional Contributor

As of this morning, Message Trace appears to be inoperable.  Only full data from 4/1 and a very small amount of data from 4/2 is available.  Anyone else seeing this?

17 Replies

@DaveBarney Message Trace isn't working for me either. I don't see any results. It either spins forever or throws an error. Also the quarantine in spins forever showing nothing. The quarantine in seems to have 4/1 and a small amount of data from 4/2 which seems similar to what you described about message trace.

Does it say anything in your service status?
If not I would suggest creating a ticket with Microsoft!

Seems to be affecting more people! I’ll let you know when I know more!!

@adam deltinger 

I didn't see anything relevant in the service status areas. I did put in a service request just now. If I find anything out, I'll post it here.

Great ! Thank you!

@AnujShroff Thanks!  Glad to hear it's not just me, first time I've seen this problem.

This would explain the slowness on my test tenant.

@Mario Pastora And now we've got an advisory on it.  Fingers crossed for a quick fix!

Great MS has acknowledged it! Hope it will be resolved soon!


@adam deltinger 


WHERE have they acknowledge this? I'm still getting shady answers from Tier1 support. Thanks!

@gatornek check there.  There is an advisory open for Message Trace.  They deployed one fix yesterday but have discovered a new issue that they are expecting to be fixed today.  Maybe.  Hopefully.

@DaveBarney Thanks bud! I have actually experienced this since Tuesday, early AM and first thing I did was check service health.  All good.  Then spent a long time with support on Tuesday when they weren't even acknowledging the problem. Glad they finally fessed up.

@gatornek Yeah, it wasn't until after I started this thread just to see if it was my issue only (before contacting support) that the advisory went up.  Looking at 6 hours until the issue is fully fixed according to their latest, but I'd check in a couple because it sounds like it may progressively get better.

I'm starting to see data from today.  The message I'm hunting for was back on Wednesday and it's still not showing up, but I've got solid data for today.  Advisory says they are processing the backlog, so hopefully before EOD today we'll have Message Trace back!

@DaveBarney It's been over a week and message trace is still not working (I use it to figure out where phishing emails were sent when the message is BCC'd).


If anything does show up in the trace it shows "Getting status" and that's it.


Also Quarantine keeps reloading old messages which I've deleted (after I reviewed and/or released).


When I contacted Premium Support, they tried to show me how to use the Quarantine.   

Geez, are they completely out of the loop or what??? They're always so surprised I'm reporting an issue (as if it's only affecting us).


I haven't seen Microsoft have issues linger so long.  

@W12345678 What I'm now seeing is messages (before they didn't show up at all) and for most I'm getting status info.  Some are still showing getting status, but it's the exception as of today.


They still have the service health advisory up saying that they will have all the old traces processed in the next few days, I don't know if that just means those that submitted longer traces (anything older than 10 days requiring offline processing) or if they're still catching up on everything.  Suited my purpose for now as I found the messages I needed.


Quarantine is a bit different.  I've not touched that over the last week so I don't know how that's working right now.  I have seen lot of dashboard items blank as I'm working on other things, and they have launched the new Security/Compliance sites, so I'm betting they've got bigger issues that aren't out there yet.  There's no health advisory for it, so if support isn't taking tickets for that issue I don't know what they're doing either...

Seem to still be ongoing. I'm getting service unavailable 503 error when trying to download reports.

Anyone have any updates?


Edit: 26 minutes later - Seems to not error now and I'm able to download the reports