Local Remote Desktop and Fire Sharing authentication fails when Azure AD MFA enabled

%3CLINGO-SUB%20id%3D%22lingo-sub-850483%22%20slang%3D%22en-US%22%3ELocal%20Remote%20Desktop%20and%20Fire%20Sharing%20authentication%20fails%20when%20Azure%20AD%20MFA%20enabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-850483%22%20slang%3D%22en-US%22%3E%3CDIV%20class%3D%22js-vote-count%20grid--cell%20fc-black-500%20fs-title%20grid%20fd-column%20ai-center%22%3E%3CP%3EWe%20have%20local%20network%20at%20office%2C%20Users%20connect%20from%20PCs%20to%20Workstations%20via%20Windows%20Remote%20Desktop.%20All%20systems%20are%20Windows%2010%20and%20joined%20to%20Azure%20AD%20(Office365)%3B%20It%20works%20but%20when%20i%20enable%20MFA%20for%20a%20user%2C%20authentication%20always%20fails!%20Users%20get%20%3CFONT%20color%3D%22%23FF0000%22%3EThe%20logon%20attempt%20failed%3C%2FFONT%3E.%20error%20message%20on%20credential%20prompt.%3C%2FP%3E%3CP%3ESame%20happens%20for%20windows%20file%20sharing%2C%20MFA%20enabled%20users%20can't%20access%20to%20local%20network%20folders.%3C%2FP%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-850483%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOn-Premises%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-850605%22%20slang%3D%22en-US%22%3ERE%3A%20Local%20Remote%20Desktop%20and%20Fire%20Sharing%20authentication%20fails%20when%20Azure%20AD%20MFA%20enabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-850605%22%20slang%3D%22en-US%22%3E%3CA%20href%3D%22https%3A%2F%2Fsaffronghaenat.ir%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsaffronghaenat.ir%2F%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1068805%22%20slang%3D%22en-US%22%3ERe%3A%20Local%20Remote%20Desktop%20and%20Fire%20Sharing%20authentication%20fails%20when%20Azure%20AD%20MFA%20enabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1068805%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F149225%22%20target%3D%22_blank%22%3E%40Amir%20Hossein%20Hodjati%20Pour%3C%2FA%3EI'm%20facing%20the%20same%20issue%2C%20were%20you%20able%20to%20resolve%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1069825%22%20slang%3D%22en-US%22%3ERe%3A%20Local%20Remote%20Desktop%20and%20Fire%20Sharing%20authentication%20fails%20when%20Azure%20AD%20MFA%20enabled%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1069825%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F490646%22%20target%3D%22_blank%22%3E%40rzzzzz%3C%2FA%3EIt%20still%20doesn't%20work%20with%20password%2C%20windows%20PIN%20works.%3C%2FP%3E%3CP%3ESetup%20PIN%20for%20the%20users%20(from%20%22%3CEM%3ESign-in%20options%3C%2FEM%3E%22%20in%20windows%20settings)%20and%20try%20to%20use%20%3CEM%3EMore%20Options%3C%2FEM%3E%26gt%3B%3CEM%3EPIN%3C%2FEM%3E%20when%20windows%20asked%20for%20credentials.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

We have local network at office, Users connect from PCs to Workstations via Windows Remote Desktop. All systems are Windows 10 and joined to Azure AD (Office365); It works but when i enable MFA for a user, authentication always fails! Users get The logon attempt failed. error message on credential prompt.

Same happens for windows file sharing, MFA enabled users can't access to local network folders.

2 Replies
Highlighted

@Amir Hossein Hodjati PourI'm facing the same issue, were you able to resolve this?

Highlighted

@rzzzzzIt still doesn't work with password, windows PIN works.

Setup PIN for the users (from "Sign-in options" in windows settings) and try to use More Options>PIN when windows asked for credentials.