la funcion SI anidada de excel , no esta trabajando en la version de Ofiice 365

%3CLINGO-SUB%20id%3D%22lingo-sub-928082%22%20slang%3D%22es-ES%22%3Ethe%20nested%20SI%20function%20of%20excel%2C%20is%20not%20working%20on%20the%20version%20of%20Ofiice%20365%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-928082%22%20slang%3D%22es-ES%22%3E%3CP%3EI%20tell%20you%20that%20I%20am%20using%20the%20nested%20SI%20Function%20and%20it%20does%20not%20work%20correctly%2C%20it%20only%20returns%20the%20data%20required%20for%20the%20first%20option%2C%20from%20the%20second%20option%20onwards%2C%20it%20no%20longer%20works%3C%2FP%3E%3CP%3ESI(%3CSTRONG%3E%3CFONT%20color%3D%22%23FF0000%22%3E%24D%2415-1%2C%3C%2FFONT%3E%3C%2FSTRONG%3EVLOOKUP(%24A23%2CINVENTORY!%24B%246%3A%24J%24500%2C6%2CSI(%24D%2415-2%2CVLOOKUP(%24A23%2CINVENTORY!%24B%246%3A%24J%24500%2C7%2CSI(%24D%2415-3%2CVLOOKUP(%24A23%2CINVENTORY!%24B%246%3A%24J%24500%2C6%2C0))))%3C%2FP%3E%3CP%3EI%20leave%20you%20a%20copy%20of%20the%20formula%20I'm%20using.%3C%2FP%3E%3CP%3Eit%20only%20works%20when%20the%20value%20of%20%3CSTRONG%3E%3CFONT%20color%3D%22%23FF0000%22%3E%24D%2415-1%2C%20%3C%2FFONT%3E%3C%2FSTRONG%3E%20%3CFONT%20color%3D%22%23FF0000%22%3E%3CFONT%20color%3D%22%23000000%22%3Efor%20values%20of%202%20and%203%20does%20not%20work.%3C%2FFONT%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23FF0000%22%3E%3CFONT%20color%3D%22%23000000%22%3EI%20hope%20you%20can%20help%20me%20to%20solve%20my%20problem%3C%2FFONT%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23FF0000%22%3E%3CFONT%20color%3D%22%23000000%22%3EThank%20you%3C%2FFONT%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%3CFONT%20color%3D%22%23FF0000%22%3E%3CFONT%20color%3D%22%23000000%22%3EBest%20regards%3C%2FFONT%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-928082%22%20slang%3D%22es-ES%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Visitor

Les comento que estoy utilizando la Función SI anidada y no me funciona correctamente, ya solo regresa el dato requerido para la primera opción, de la segunda opción en adelante, ya no funciona

=SI($D$15=1,BUSCARV($A23,INVENTARIO!$B$6:$J$500,6,SI($D$15=2,BUSCARV($A23,INVENTARIO!$B$6:$J$500,7,SI($D$15=3,BUSCARV($A23,INVENTARIO!$B$6:$J$500,6,0))))))

les dejo una copia de la formula que estoy utilizando.

solo funciona cuando el valor de $D$15=1, para los valores de 2 y 3 no funciona.

espero que me puedan auxiliar para la solución de mi problema

gracias

saludos

 

0 Replies