Issues during migrating few users from onprem to O365

Occasional Contributor

I have couple of users and i am facing this issue for 5 mailbox they are fully synced but when iam clicking on mark as complete for the batch iam getting below error .


Error: MigrationTransientException: Couldn‎'t find a move request that corresponds to the specified identity.

I have removed them from the batch started fresh sync but then also iam getting same error .


Please help 

19 Replies


Did you enable the MRSProxy service or not while migrating the mailboxes?

If the MRSProxy service isn't already enabled for your on-premises Exchange servers, follow these steps in the Exchange admin center (EAC):


1. Open the EAC, and then navigate to Servers > Virtual Directories.

2. Select the Client Access server, and then select the EWS virtual directory and click Edit.

3. Select the MRS Proxy enabled check box, and then click Save.


This will enable the MRSProxy service. Then you can move the mailboxes to Office 365.






I have already moved 5 mailbox already to O365 , this is specific issue with the 5 mailbox only.






So the mailboxes all sync, and the error occurs when you click to complete the migration batch?  


Have you tried connecting to Exchange Online PowerShell and running;


Resume-MoveRequest -Identity ""

Iam already using powershell also and suspended and resume already .



OK, since the move request was set off, the source AD object was not moved to another OU by any chance was it?

I have not moved the user object to non sync Ou. the main idea behind this is to convert the Online users mailbox to mail user ?


even if you remove the license  then also it will become a mail user .



Sorry, I'm getting confused now.  Remote Mailbox move from on-prem to EOL will convert the online mail user object to a mailbox, not the other way around.  This is what you are trying to achieve right?


Does the mailbox still currently reside on-prem, and has the move request now been cancelled / removed?



you are right i want to move mailbox from On prem to O365.


Yes mailbox still resides in On prem . it has completed with error , when i look at individual mailbox they are failed .


I have not yet removed the batch yet 





OK, I would suggest removing the batch, then start the move requests again.  As you have had some difficulties here I would also suggest setting individual move requests instead of a migration batch.  


Maybe try one to begin with, and also increase the bad item count/limit just as an extra precaution.

@PeterRising I have removed all the faulty users and again started sync for each and every user individually not in a batch . I have tested for one user and assigned a licence. again when i have completed by command then 


MigrationTransientException: Mailbox ‎'Customer Service‎' is not currently being moved. --> Mailbox ‎'Customer Service‎' is not currently being moved.  



OK, do you have more than one database in your Exchange On-prem environment.  If so, try and first move one of the mailboxes to a different database, then try to move online again if successful.  I have seen this work before for problem mailbox moves.

@PeterRising I dont have other DB but i can create and will do the same and will let you know how it goes.

 @PeterRising  I have moved a user to different DB and removed the sync from O365 , run resync then also the same issue is coming when i click on mark as comeplete.






It says 


The onboarding move could not be created because user ‎'Apple DEP‎' is already being moved.


when i check in the exchange online shell it says no move request is found related to the user exchange online shell says 

Couldn't find a move request that corresponds to the specified identity



OK, afraid I'm running out of ideas here now.  If I were in your position right now and had exhausted all of these steps, I'd be starting to look at backing up the mailboxes to pst and migrating manually to O365 just to get the process completed.  Not ideal I know, but at least it would get it done for you.


Only other suggestion I would have is to log a support ticket with Microsoft and see if they have any further suggestions.



I have logged a case with MS they are also escalating this to there further level . because items are completely synced but when it comes to cloud it shows less items and instead change in the status of inside the move in the details pane it only shows synced rather than its suppose to show as completing .


so waiting for the response from MS to come 



I hope they can solve the issue for you.  Please let me know what happens.

best response confirmed by Abhayk84 (Occasional Contributor)



MS has given the formula to use 


Remove-msoluser -userprincipalnaem ***** and

remove-MSOLuser -userprincipalname *** -removefromrecyclebin


use these two commands as this good for a user i was facing issue it was completed 100% and for 2 users move was also there in hybrid for moving 2 users to different DB. After removing moves for 2 users in hybrid and restarting them in online its working . and for one user its working fine . Now everything is working as expected .






Excellent, thanks for updating with the solution.