Internal error: An unexpected error occurred

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3153324%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bzh-CN%5C%26quot%3B%22%3EInternal%20error%3A%20An%20unexpected%20error%20occurred%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3153324%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bzh-CN%5C%26quot%3B%22%3E%3CP%3EThis%20problem%20has%20been%20bothering%20me%20for%20a%20long%20time.%20When%20I%20use%20the%20Analyze%20in%20Excel%20feature%20in%20Power%20BI%20and%20open%20the%20downloaded%20files%20in%20Excel%2C%20I%20get%20the%20following%20error.%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%5C%26quot%3Blia-inline-image-display-wrapper%22%20lia-image-align-inline%3D%22%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fgxcuf89792%2F%5C%26quot%3Bhttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F347255i2A26478244B09818%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%5C%26quot%3B%22%20role%3D%22%5C%26quot%3Bbutton%5C%26quot%3B%22%20title%3D%22Winkk_0-1644568525382.png%22%20alt%3D%22%5C%26quot%3BWinkk_0-1644568525382.png%5C%26quot%3B%22%20%2F%3E%26lt%3B%5C%2Fspan%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%5C%26quot%3Blia-inline-image-display-wrapper%22%20lia-image-align-inline%3D%22%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fgxcuf89792%2F%5C%26quot%3Bhttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F347256iC9C27702A58E4329%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%5C%26quot%3B%22%20role%3D%22%5C%26quot%3Bbutton%5C%26quot%3B%22%20title%3D%22Winkk_1-1644568588960.png%22%20alt%3D%22%5C%26quot%3BWinkk_1-1644568588960.png%5C%26quot%3B%22%20%2F%3E%26lt%3B%5C%2Fspan%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EI%20am%20sure%20that%20it%20is%20set%20up%20correctly%20in%20Power%20BI.%20This%20problem%20appears%20suddenly%20and%20exists%20for%20all%20reports.%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EAnd%20when%20I%20want%20to%20connect%20directly%20from%20Excel%20to%20Power%20BI%2C%20I%20can't%20find%20the%20Power%20BI%20data%20source%20and%20I%20don't%20know%20if%20I%20have%20wrong%20somewhere.%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%5C%26quot%3Blia-inline-image-display-wrapper%22%20lia-image-align-inline%3D%22%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fgxcuf89792%2F%5C%26quot%3Bhttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F347257i563782142D94A901%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%5C%26quot%3B%22%20role%3D%22%5C%26quot%3Bbutton%5C%26quot%3B%22%20title%3D%22Winkk_2-1644568753175.png%22%20alt%3D%22%5C%26quot%3BWinkk_2-1644568753175.png%5C%26quot%3B%22%20%2F%3E%26lt%3B%5C%2Fspan%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EI%20didn't%20find%20a%20solution%20online%20and%20I%20hope%20someone%20can%20help%20me%2C%20thanks%20in%20advance.%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3CLINGO-LABS%20id%3D%22%5C%26quot%3Blingo-labs-3153324%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Bzh-CN%5C%26quot%3B%22%3E%3CLINGO-LABEL%3EExcel2016%26lt%3B%5C%2Flingo-label%26gt%3B%3CLINGO-LABEL%3ENeed%20Excel%20Help%26lt%3B%5C%2Flingo-label%26gt%3B%3CLINGO-LABEL%3EPower%20BI%26lt%3B%5C%2Flingo-label%26gt%3B%26lt%3B%5C%2Flingo-labs%26gt%3B%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E
Visitor

This problem has been bothering me for a long time. When I use the Analyze in Excel feature in Power BI and open the downloaded files in Excel, I get the following error.

 

Winkk_0-1644568525382.png

Winkk_1-1644568588960.png

 

I am sure that it is set up correctly in Power BI. This problem appears suddenly and exists for all reports. My excel version is 2016.

 

And when I want to connect directly from Excel to Power BI, I can't find the Power BI data source and I don't know if I have wrong somewhere.

 

Winkk_2-1644568753175.png


I didn't find a solution online and I hope someone can help me, thanks in advance.

 

 

0 Replies