Imap problem in Office365, basic auth

Occasional Visitor

Hi, I have problem with basic auth login to imap service. 

Cant login with basic auth to imap server. Connectivity analyzer error below.
User have acces to iamp/pop3/smtp, same with turn off modern auth. 

Please verify There was an error testing the IMAP service Collapse Additional Details Protocol Log: C: 1 CAPABILITY S: * OK The Microsoft Exchange IMAP4 service is ready. [RABCADMAUABSADAAOABDAEEAMAAwADEANwAuAGUAdQByAHAAcgBkADAAOAAuAHAAcgBvAGQALgBvAHUAdABsAG8AbwBrAC4AYwBvAG0A] S: * CAPABILITY IMAP4 IMAP4rev1 AUTH=PLAIN AUTH=XOAUTH2 SASL-IR UIDPLUS ID UNSELECT CHILDREN IDLE NAMESPACE LITERAL+ S: 1 OK CAPABILITY completed. C: 2 LOGIN m.kochanowski@ksservice.pl ******** S: 2 NO LOGIN failed. Exception details: Message: The IMAP server responded with an error status "2 NO LOGIN failed.". Type: Microsoft.M365.RCA.Services.Protocols.Imap.ImapServerErrorException Stack trace: at Microsoft.M365.RCA.Services.Protocols.Imap.ImapCommand`1.CheckForOk(IList`1 response) at Microsoft.M365.RCA.Services.Protocols.Imap.LoginCommand.ProcessResponse(IList`1 response) at Microsoft.M365.RCA.Services.Protocols.ProtocolClient.[SendCommandAsync]d__17`1.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw() at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at Microsoft.M365.RCA.ConnectivityTests.ImapPop.BaseProtocolTest.[PerformTestInternalAsync]d__12.MoveNext()
  •  
3 Replies
Have you made sure that basic authentication is not turned off for your user/tenant? Also check whether the IMAP protocol itself is enabled.

@Vasil Michev 

 

Basic Authentication is on and IMAP is enabled for the user, but still getting this error

Hi @Sunildara ,

 

check is Microsoft maybe disabled basic authentication for your tenant, you might want to opt-out.

Login as administrator.

 

Adin_Calkic_0-1651771334326.png

 

Click on Help. Type in and Diag: Enable Basic Auth in EXO Run.

Adin_Calkic_1-1651771341130.png

 

Select your protocol.

 

Adin_Calkic_2-1651771392176.png

 

 

You could have these issue for multiple reasons. This is just one of them. You can read about Opt out solution here - Basic Authentication and Exchange Online – September 2021 Update - Microsoft Tech Community