I have a question about using SMTP after setting up MFA.

%3CLINGO-SUB%20id%3D%22lingo-sub-1719406%22%20slang%3D%22en-US%22%3EI%20have%20a%20question%20about%20using%20SMTP%20after%20setting%20up%20MFA.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1719406%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%3C%2FP%3E%3CP%3EWhat%20I%20am%20trying%20to%20do%20is%20set%20up%20the%20MFA%20and%20send%20email%20using%20the%20SMTP%20function.%3C%2FP%3E%3CP%3EI%20installed%20the%20Authenticator%20app%20and%20completed%20the%20MFA%20setup%20for%20my%20personal%20account.%20I%20didn't%20set%20anything%20else.%20In%20this%20case%2C%20I%20can%20send%20an%20email%20using%20SMTP.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20I%20thought%2C%20because%20of%20setting%20up%20MFA%2C%20I%20thought%20I%20wouldn't%20be%20able%20to%20use%20SMTP.%20Or%20thought%20additional%20certification%20would%20be%20necessary.%20But%20there%20was%20no%20such%20problem.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20there%20no%20problem%20because%20I%20tested%20it%20with%20my%20personal%20account%3F%3C%2FP%3E%3CP%3EOr%20is%20the%20use%20of%20MFA%20and%20SMTP%20irrelevant%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHere%20is%20SMTP%20test%20code%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Seyoon_Park_0-1601288043395.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F222523i96330B974BE4FEE2%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22Seyoon_Park_0-1601288043395.png%22%20alt%3D%22Seyoon_Park_0-1601288043395.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1719406%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDeveloper%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20Apps%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1719737%22%20slang%3D%22en-US%22%3ERe%3A%20I%20have%20a%20question%20about%20using%20SMTP%20after%20setting%20up%20MFA.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1719737%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F811505%22%20target%3D%22_blank%22%3E%40Seyoon_Park%3C%2FA%3E%26nbsp%3BHi%2C%20as%20far%20as%20I%20know%20you%20should%20be%20prompted%20for%20an%20app%20password%20when%20enabling%20MFA%20using%20smtp.%20Not%20sure%20what%20you're%20trying%20to%20do%20but%20sounds%20like%20something%20similar%20to%20this%3F%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fmail-flow-best-practices%2Fhow-to-set-up-a-multifunction-device-or-application-to-send-email-using-microsoft-365-or-office-365%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fexchange%2Fmail-flow-best-practices%2Fhow-to-set-up-a-multifunction-device-or-application-to-send-email-using-microsoft-365-or-office-365%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1721156%22%20slang%3D%22en-US%22%3ERe%3A%20I%20have%20a%20question%20about%20using%20SMTP%20after%20setting%20up%20MFA.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1721156%22%20slang%3D%22en-US%22%3E%3CP%3EYou%20cannot%20just%20reuse%20old%20code%20for%20this%2C%20you%20need%20to%20leverage%20OAuth%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fexchange-team-blog%2Fannouncing-oauth-2-0-support-for-imap-and-smtp-auth-protocols-in%2Fba-p%2F1330432%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fexchange-team-blog%2Fannouncing-oauth-2-0-support-for-imap-and-smtp-auth-protocols-in%2Fba-p%2F1330432%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1721423%22%20slang%3D%22en-US%22%3ERe%3A%20I%20have%20a%20question%20about%20using%20SMTP%20after%20setting%20up%20MFA.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1721423%22%20slang%3D%22en-US%22%3ELove%20jumping%20into%20these%20%E2%80%9Dprotocol%20questions%E2%80%9D%20as%20I%20know%20you%20will%20reply%20and%20enlighten%20me%20%3A)%3C%2Fimg%3E%20But%20shouldn%E2%80%99t%20he%20be%20prompted%20without%20leverage%20OAuth%3F%20I%E2%80%99m%20certain%20I%E2%80%99ve%20read%20about%20it%20somewhere.%20Now%20I%20didn%E2%80%99t%20really%20look%20at%20the%20code%20to%20be%20honest%20but%20I%20suppose%20it%20wasn%E2%80%99t%20about%20Direct%20send%20then%20(on%20mobile).%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

Hi.

What I am trying to do is set up the MFA and send email using the SMTP function.

I installed the Authenticator app and completed the MFA setup for my personal account. I didn't set anything else. In this case, I can send an email using SMTP.

 

The problem I thought, because of setting up MFA, I thought I wouldn't be able to use SMTP. Or thought additional certification would be necessary. But there was no such problem.

 

Is there no problem because I tested it with my personal account?

Or is the use of MFA and SMTP irrelevant?

 

Here is SMTP test code:

Seyoon_Park_0-1601288043395.png

 

 

7 Replies
Highlighted

@Seyoon_Park Hi, as far as I know you should be prompted for an app password when enabling MFA using smtp. Not sure what you're trying to do but sounds like something similar to this? https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/how-to-set-up-a-multifunction-dev...

Highlighted
Highlighted
Love jumping into these ”protocol questions” as I know you will reply and enlighten me :) But shouldn’t he be prompted without leverage OAuth? I’m certain I’ve read about it somewhere. Now I didn’t really look at the code to be honest but I suppose it wasn’t about Direct send then (on mobile).
Highlighted

Hi @Vasil Michev 

I read the article you linked. However, it is about SMTP and Exchange Online. All l'm trying to do is send an email using SMTP and end it. Is this related to Exchange Online?

I don't think it's relevant.

 

 

Highlighted

Hi @bec064 

As you said, when I complete the MFA setup, a pop-up will pop up asking me to enter my app password when I log in. However, when sending an email using SMTP in code, no pop-up occurs.

I have read the article you linked, but this is also related to exchange online. What I don't understand now is what SMTP and Exchange Online have to do with it.

Can I know what Exchange Online and SMTP have to do with it?

Highlighted

@Seyoon_Park Hello, well according to your attached info you're using SMTP with the setting smtp.office365.com (online) to send, so would you mind elaborate what you're trying to accomplish and how your environment is set up.

@bec064 Hello,

 

Trying to accomplish:

1. Set up MFA in my account.

2. To find out if MFA has no effect on SMTP.

3. I thought setting MFA would require additional settings for SMTP, but it didn't matter at all, so I'm asking because it's werid.

 

My environment:

1. There is nothing but the MFA setting and the code above.