I can't receive any e-mails on Office 365 group's e-mail address and can't even delete the group

Occasional Contributor

Few days ago, I created an Office 365 group. I can't receive any e-mails on that group's e-mail address. When I send something from my private e-mail I get response from which says that my message can't be delivered.


The group is visible under groups tab in the Admin center. I tried to recreate the group, however, I couldn't even delete the group. It reappears after deletion. I waited more than 24 hours. Nothing.


I'd like to ask for help here. I created a ticket but got no response. I tried to call support but that was without success either. I waited 12 minutes on the line just to hear a greetings from the second consultant that I was redirected to and then got disconnected.

13 Replies

I assume that email is accepted for other recipients in the tenant?


If so, can you check the email addresses assigned to the group and make sure that you are using the right one. It's easy to make a mistake:


[PS] C:\> Get-UnifiedGroup -Id GroupAlias | Format-List EmailAddresses


When you are sure that you are using the right address (any of those listed should work), you can post the NDR here and we will look at it to see if any clues exist.

No e-mails are delivered to any of the users assigned to the group.
I re-checked group id on Admin center. It matches the one I'm trying to send an e-mail.
I'd like to add that other groups are working fine.

The NDR:

Original Message Details
Created Date: 9/5/2017 12:54:57 PM
Sender Address:
Recipient Address:
Subject: te

Error Details
Reported error: 550 5.1.10 RESOLVER.ADR.RecipientNotFound; Recipient not found by SMTP address lookup
DSN generated by: AM5SPR00MB248.EURP195.PROD.OUTLOOK.COM
Message Hops
1 9/5/2017
12:54:57 PM HTTP *
2 9/5/2017
12:55:18 PM SMTP 21 sec
3 9/5/2017
12:55:18 PM Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA_P384) *
4 9/5/2017
12:55:18 PM Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P256) *
5 9/5/2017
12:55:18 PM DB6P195CA0021.EURP195.PROD.OUTLOOK.COM AM5SPR00MB248.EURP195.PROD.OUTLOOK.COM Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P256) *
Original Message Headers
Received: from DB6P195CA0021.EURP195.PROD.OUTLOOK.COM (2603:10a6:4:cb::31) by
AM5SPR00MB248.EURP195.PROD.OUTLOOK.COM (2603:10a6:203:8e::21) with Microsoft
SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P256) id; Tue, 5 Sep
2017 12:55:18 +0000
Received: from
(2a01:111:f400:7e02::208) by
(2603:10a6:4:cb::31) with Microsoft SMTP Server (version=TLS1_2,
cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384_P256) id via
Frontend Transport; Tue, 5 Sep 2017 12:55:18 +0000
Authentication-Results: spf=pass (sender IP is;; dkim=pass (signature was verified);; dmarc=pass action=none;
Received-SPF: Pass ( domain of designates as permitted sender);
Received: from ( by ( with Microsoft SMTP
Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA_P384) id
15.1.1385.11 via Frontend Transport; Tue, 5 Sep 2017 12:55:18 +0000
Received: by with SMTP id f145so11024540wme.0
for <>; Tue, 05 Sep 2017 05:55:18 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20161025;
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;; s=20161025;
X-Gm-Message-State: AHPjjUjeGJkpQPHI0guM/QHqQ54VUQ7/kueQvZMPXVgaijKxLzz07Sw2
X-Google-Smtp-Source: ADKCNb76V9mRUjn0n6fyPKF7Z/47hINAb8k3YaQEIQa6WQaiAdLRY4zeq/EMzlRpEUR3UPguTlX5O2t2wivKb9D0P1o=
X-Received: by with SMTP id e24mr3132188edd.4.1504616117450;
Tue, 05 Sep 2017 05:55:17 -0700 (PDT)
MIME-Version: 1.0
Received: by with HTTP; Tue, 5 Sep 2017 05:54:57 -0700 (PDT)
From: =?UTF-8?B?TWljaGHFgiBLaWXFgnR5a2E=?= <>
Date: Tue, 5 Sep 2017 14:54:57 +0200
Message-ID: <>
Subject: te
Content-Type: multipart/alternative; boundary="f403045c2ca4343c7a055870bdea"
X-EOPAttributedMessage: 0
X-EOPTenantAttributedMessage: 9c5a6e47-89e8-49b5-a275-b5a783986b3d:0
X-Forefront-Antispam-Report: CIP:;IPV:NLI;CTRY:US;EFV:NLI;
X-Microsoft-Exchange-Diagnostics: 1;DB5EUR01FT048;1:DcEOEnSlol6w5NlGBcNr6pM/e4UP8h4HOBRMxm47T7kIbEyC2ocU912iLnIGC+Ygf0VTm1IOC41F97HWox/dzZALDSIOgj94qu1RuoNdWBXcaUBDGYRqBPan3SM/GV1l
X-MS-PublicTrafficType: Email
X-MS-Office365-Filtering-Correlation-Id: b7c679ea-303d-458c-4302-08d4f45d5c75
X-DkimResult-Test: Passed
X-MS-TrafficTypeDiagnostic: AM5SPR00MB248:

Final-Recipient: rfc822;
Action: failed
Status: 5.1.10
Diagnostic-Code: smtp;550 5.1.10 RESOLVER.ADR.RecipientNotFound; Recipient not found by SMTP address lookup

The error says that Azure Active Directory cannot find any recipient with that email address ( in your tenant. That's why I asked you to run the PowerShell command to verify what email addresses are assigned to the group. There's no doubt that the address is invalid... so given that email is working properly for other recipients in the tenant, it's likely that you are using an incorrect address for the group. We need to go back to basics and find what address is assigned and test using that... 

Sorry for the misunderstanding. I'm new to Microsoft's eco-system.

Here's the result of the command you provided:

PS C:\Windows\system32> Get-UnifiedGroup -Id contact | Format-List EmailAddresses
The operation couldn't be performed because object 'contact' couldn't be found on 'DB6P195A002DC03.EURP195A002.PROD.OUT
+ CategoryInfo : NotSpecified: (:) [Get-UnifiedGroup], ManagementObjectNotFoundException
+ FullyQualifiedErrorId : [Server=HE1P195MB0123,RequestId=b1fe601d-1edd-4964-b94b-0c85b10388c5,TimeStamp=2017-09-0
6 10:09:19] [FailureCategory=Cmdlet-ManagementObjectNotFoundException] 1061B38C,Microsoft.Exchange.Management.Reci
+ PSComputerName :


If I try to create the group:

PS C:\Windows\system32> New-UnifiedGroup -DisplayName "contact" -Alias "contact" -AccessType Private
The alias is being used by another group in your organization. Please try a different alias.
    + CategoryInfo          : NotSpecified: (:) [New-UnifiedGroup], TaskException
    + FullyQualifiedErrorId : [Server=HE1P195MB0123,RequestId=aae35759-c08d-43b3-b30c-29c93f98d3d2,TimeStamp=2017-09-0
   6 11:26:35] [FailureCategory=Cmdlet-TaskException] A34FE7CE,Microsoft.Exchange.Management.RecipientTasks.NewUnifie
    + PSComputerName        :
Is contact the alias for the group? It is odd that the directory is not returning information about the group. Can you access the group from OWA?

I'm assigned to 'contact' group in Admin center but I can't see that group in OWA:



I'm assigned to 'apirequest' group as well which works OK.


Here's a screenshot from Admin center:

Here you can see bugged 'contact' group.

And here is 'apirequest' group which works fine:


OK, and you're testing with a Gmail account - which means that the group properties have to allow it to accept email from another domain. I can't send email to either because your tenant won't accept the message.You should check the value of the group's RequireSenderAuthenticationEnabled property. If it is True, it means that only authenticated senders can send messages to the group. If False, anyone from any domain (including Gmail) can. It could be as simple as that...


Get-UnifiedGroup -Id Contact | Fl RequireSenderAuthenticationEnabled

Sometimes it takes a little while for OWA to display a new group. Because you can see it in Office 365 Admin, the group does exist in the directory, so that's fine. 

Result of the provided command:

PS C:\Windows\system32> Get-UnifiedGroup -Id Contact | Fl RequireSenderAuthenticationEnabled
The operation couldn't be performed because object 'Contact' couldn't be found on 'DB6P195A002DC03.EURP195A002.PROD.OUT
    + CategoryInfo          : NotSpecified: (:) [Get-UnifiedGroup], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : [Server=HE1P195MB0123,RequestId=38412ee6-7254-4781-9894-9b645839ed5e,TimeStamp=2017-09-0
   6 12:05:18] [FailureCategory=Cmdlet-ManagementObjectNotFoundException] 1050376C,Microsoft.Exchange.Management.Reci
    + PSComputerName        :

I tried with lowercase 'contact' either. The same error.


'contact' group settings in Admin center:

And please bear in mind that I'm not able to delete the group (it reappears) as well as receive any e-mails. I'm trying to resolve the problem since Monday or before, so it's not something that would resolve itself over time.


Microsoft Support just called me, they were sorry that it took so long, we were talking about the problem and I'm waiting now for some commands that I should execute in PowerShell since they had similar problem few weeks ago.

Ok. Let's leave this to the support people to sort out as they can access the info to see what is going on.
best response confirmed by Michał Kiełtyka (Occasional Contributor)

Thank you for your answers. The problem has been solved with help from Microsoft Support.

For anyone experiencing the same, execute these commands in Windows Azure Active Directory:

Set-ExecutionPolicy Unrestricted -Force
$User = Get-Credential
Connect-MsolService -Credential $User

Remove-MsolGroup -ObjectID d7e7f7g7-a6a6-4444-b9c9-h1g2f3e4d5c6

Where d7e7f7g7-a6a6-4444-b9c9-h1g2f3e4d5c6 is just an example of ObjectID of the bugged group shown on the list from the previous command.

It's good that the problem is resolved, but it would be better if you understood why the problem occurred in the first place. Did Microsoft support figure things out or did they fix the issue by simply blowing away the group object in Azure Active Directory?  Although effective, it seems an odd approach to me - kind of like using the famous ADSIEdit utility to remove the object for Exchange servers you no longer want by performing "brain surgery" on Active Directory...



@Michał Kiełtyka 

I  am wondering if this command is for deleting the group?