SOLVED

Guest users do not receive Office Group conversations

%3CLINGO-SUB%20id%3D%22lingo-sub-1450452%22%20slang%3D%22en-US%22%3EGuest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1450452%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20Everyone!%3C%2FP%3E%3CP%3EI%20encountered%20the%20following%20problem%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20are%20some%20Office%20Group%20members%20(external%20users)%2C%20who%20do%20not%20receive%20emails%20-%20group%20conversations.%3C%2FP%3E%3CP%3EI%20have%20reported%20this%20issue%20to%20Microsoft%20Support%2C%20but%20unfortunately%2C%20it%20was%20not%20solved.%3C%2FP%3E%3CP%3EIn%20Exchange%20'External%20Email%20Address'%20for%20those%20users%20is%20empty%20-%20it%20has%20been%20set%20during%20user%20creation%2C%20but%20it%20disappears%20after%20some%20time.%3C%2FP%3E%3CP%3ESetting%20External%20Emails%20Address%20back%20didn't%20resolve%20the%20problem.%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20verified%20this%20article%20(%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fguest-doesn-t-receive-group-email-conversations-b9891873-c33c-415a-8751-66a64d17f06c%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3E%3CSPAN%3Ehttps%3A%2F%2Fsupport.office.com%2Fen-us%2Farticle%2Fguest-doesn-t-receive-group-email-conversations-b9891873-c33c-415a-8751-66a64d17f06c%3C%2FSPAN%3E%3C%2FA%3E%3CSPAN%3E)%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%20but%20the%20group%20settings%20are%20set%20correctly%2C%20as%20well%20as%20user%20properties%20(Other%20Mails%2C%20ProxyAddresses).%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBy%20using%20cmdlet%20Get-MailUser%20I%20found%20that%20there%20is%20one%20difference%20between%20mail%20user%20properties%20of%20guest%20user%20who%20doesn't%20get%20email%20and%20guest%20user%20who%20gets%20all%20group%20emails.%3C%2FP%3E%3CP%3E'Other%20Mail'%20property%20is%20empty.%20I've%20looked%20on%20how%20to%20change%20it%20via%20PowerShell%2C%20but%20I%20couldn't%20find%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMaybe%20someone%20had%20such%20a%20problem%20and%20knows%20how%20to%20solve%20it%20without%20having%20to%20recreate%20user%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1450452%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%20Groups%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1451830%22%20slang%3D%22en-US%22%3ERe%3A%20Guest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1451830%22%20slang%3D%22en-US%22%3E%3CP%3E'OtherMails'%20is%20an%20attribute%20managed%20by%20Azure%20AD%20afaik%2C%20you%20cannot%20change%20it%20via%20the%20Exchange%20cmdlets.%20You%20should%20be%20able%20to%20change%20it%20via%20Set-MsolUser%2FSet-AzureADUser%20or%20the%20Graph%20API%20directly%2C%20but%20I'm%20not%20sure%20if%20such%20changes%20later%20flow%20to%20ExO.%20They%20should%20I%20suppose%2C%20so%20give%20it%20a%20try.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1453207%22%20slang%3D%22en-US%22%3ERe%3A%20Guest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1453207%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F58%22%20target%3D%22_blank%22%3E%40Vasil%20Michev%3C%2FA%3E%26nbsp%3Bthank%20you%20for%20your%20answer.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E'Other%20Mail'%20is%20not%20the%20same%20as%20'OtherMails'%20property.%3C%2FP%3E%3CP%3EIn%20my%20case%20'OtherMails'%20property%20is%20set%20correctly%20for%20all%20'problematic'%20users%20(it%20contains%20the%20user's%20email%20address).%3C%2FP%3E%3CP%3EWhen%20I'm%20comparing%20properties%20for%20guest%20user%20who%20gets%20group%20conversation%20with%20guest%20user%20who%20does%20not%2C%20only%20difference%20is%20in%20'%3CSTRONG%3EOther%20Mail%3C%2FSTRONG%3E'%20property%20(which%20I%20get%20by%20executing%20cmdlet%3A%20%3CEM%3EGet-MailUser%26nbsp%3B%20-Resultsize%20unlimited%7C%20%3F%20%7B%24_.externalemailaddress%20-match%20%22%5Bguest%20user%20email%20address%20here%22%7D%26nbsp%3B%20%7C%20fl%3C%2FEM%3E).%3C%2FP%3E%3CP%3E'Other%20Mail'%20property%20is%20empty%20for%20the%20user%20who%20doesn't%20get%20group%20conversations.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20some%20cases%20recreating%20guest%20users%20(deleting%20user%20and%20inviting%20again)%20works.%20But%20I%20have%20a%20few%20cases%20for%20which%20it%20doesn't%20work%20and%20even%20after%20recreating%20they%20still%20don't%20get%20group%20conversations%20and%20the%20'Other%20Mail'%20property%20is%20empty.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1454042%22%20slang%3D%22en-US%22%3ERe%3A%20Guest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1454042%22%20slang%3D%22en-US%22%3E%3CP%3EIt's%20exactly%20the%20same%20attribute%2C%20I've%20confirmed%20that%20changing%20it%20in%20Azure%20AD%20updates%20it%20in%20Exchange%20Online%20after%20I%20posted%20yesterday.%20In%20your%20case%20it%20probably%20got%20out%20of%20sync%2C%20so%20you%20can%20try%20setting%20it%20on%20Azure%20AD%20side%20and%20wait%20for%20synchronization%20to%20occur.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467143%22%20slang%3D%22en-US%22%3ERe%3A%20Guest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467143%22%20slang%3D%22en-US%22%3E%3CP%3EI%20set%20it%20on%20Azure%20AD%20side%20and%20now%20when%20I%20run%20Get-AzureADUser%20I%20get%20Provisioning%20Error%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22provisioningError_blur.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F198987i7D0E086E26D8B409%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22provisioningError_blur.png%22%20alt%3D%22provisioningError_blur.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20tried%20to%20wait%20for%20synchronization%20(2%20days)%20but%20the%20provisioning%20error%20still%20occurs.%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20advise%20something%3F%20Should%20I%20wait%20longer%20for%20synchronization%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1467850%22%20slang%3D%22en-US%22%3ERe%3A%20Guest%20users%20do%20not%20receive%20Office%20Group%20conversations%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1467850%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20the%20error%20message%20suggests%2C%20you%20seem%20to%20have%20another%20object%20to%20which%20this%20address%20is%20already%20assigned%2C%20which%20probably%20explains%20the%20initial%20%22empty%22%20value.%20Try%20to%20locate%20said%20object%20by%20running%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EGet-Recipient%20%3CA%20href%3D%22mailto%3Aemail%40domain.com%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eemail%40domain.com%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EOr%20open%20a%20support%20case.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hello Everyone!

I encountered the following problem:

 

There are some Office Group members (external users), who do not receive emails - group conversations.

I have reported this issue to Microsoft Support, but unfortunately, it was not solved.

In Exchange 'External Email Address' for those users is empty - it has been set during user creation, but it disappears after some time.

Setting External Emails Address back didn't resolve the problem.

I verified this article (https://support.office.com/en-us/article/guest-doesn-t-receive-group-email-conversations-b9891873-c3...)  but the group settings are set correctly, as well as user properties (Other Mails, ProxyAddresses).

 

By using cmdlet Get-MailUser I found that there is one difference between mail user properties of guest user who doesn't get email and guest user who gets all group emails.

'Other Mail' property is empty. I've looked on how to change it via PowerShell, but I couldn't find it.

 

Maybe someone had such a problem and knows how to solve it without having to recreate user?

5 Replies
Highlighted
Best Response confirmed by mbodnar (New Contributor)
Solution

'OtherMails' is an attribute managed by Azure AD afaik, you cannot change it via the Exchange cmdlets. You should be able to change it via Set-MsolUser/Set-AzureADUser or the Graph API directly, but I'm not sure if such changes later flow to ExO. They should I suppose, so give it a try.

Highlighted

@Vasil Michev thank you for your answer.

 

'Other Mail' is not the same as 'OtherMails' property.

In my case 'OtherMails' property is set correctly for all 'problematic' users (it contains the user's email address).

When I'm comparing properties for guest user who gets group conversation with guest user who does not, only difference is in 'Other Mail' property (which I get by executing cmdlet: Get-MailUser  -Resultsize unlimited| ? {$_.externalemailaddress -match "[guest user email address here"}  | fl).

'Other Mail' property is empty for the user who doesn't get group conversations.

 

In some cases recreating guest users (deleting user and inviting again) works. But I have a few cases for which it doesn't work and even after recreating they still don't get group conversations and the 'Other Mail' property is empty.

Highlighted

It's exactly the same attribute, I've confirmed that changing it in Azure AD updates it in Exchange Online after I posted yesterday. In your case it probably got out of sync, so you can try setting it on Azure AD side and wait for synchronization to occur.

Highlighted

I set it on Azure AD side and now when I run Get-AzureADUser I get Provisioning Error:

provisioningError_blur.png

I tried to wait for synchronization (2 days) but the provisioning error still occurs. 

Could you advise something? Should I wait longer for synchronization? 

Highlighted

As the error message suggests, you seem to have another object to which this address is already assigned, which probably explains the initial "empty" value. Try to locate said object by running

 

Get-Recipient email@domain.com 

 

Or open a support case.