FocusedInboxOn parameter cannot be found

Occasional Contributor

I am trying to enable Focused Inbox for everyone in my organization. When I follow the instructions here: I receive the following error:

Set-OrganizationConfig -FocusedInboxOn $true
A parameter cannot be found that matches parameter name 'FocusedInboxOn'.
    + CategoryInfo          : InvalidArgument: (:) [Set-OrganizationConfig], ParameterBindingException
    + FullyQualifiedErrorId : NamedParameterNotFound,Set-OrganizationConfig
    + PSComputerName        :

9 Replies

If you run Get-OrganizationConfig, do you see the FocusedInboxOn set to $false?

The parameter might not be available depending on the permissions you have, to be on the safe side make sure to run it as Global administrator (or any member of the "Organization Configuration" role group). In addition, it might not be available for certain "flavors" of O365, say the German cloud.

When I run Set-OrganizationConfig I the following:

GuestsUsageGuidelinesLink                                 :
FocusedInboxOn                                            :
FocusedInboxOnLastUpdateTime                              : 1/1/0001 12:00:00 AM
ForestConfigVersion                                       :


I am in the US so not sure why this would not work.

Also, I am executing this as a Global Admin so it should not be a permissions issue.

Does set-focusedinbox and get-focusedinbox work on induvidual mailboxes?

Thank you for your help.

No, those commands do not exist per this error message:

Get-FocusedInbox : The term 'Get-FocusedInbox' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name,
or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ Get-FocusedInbox
+ ~~~~~~~~~~~~~~~~
    + CategoryInfo          : ObjectNotFound: (Get-FocusedInbox:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

Any solution to this?  I have the same blank parameter from the get-organizationconfig cmdlet.  I am running as global admin.

No and it is still not working for me.

@Tom HarrisDid you ever get this working, I have the same issue?