Exchange Online Email Alias Where to Add

%3CLINGO-SUB%20id%3D%22lingo-sub-938389%22%20slang%3D%22en-US%22%3EExchange%20Online%20Email%20Alias%20Where%20to%20Add%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-938389%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20question%20is%20not%20about%20how%20to%20add%20but%20I've%20noticed%20a%20change%20and%20native%20way%20of%20adding%20a%20new%20email%20alias%20via%20Exchange%20online%20mailbox%20properties%20does%20not%20seems%20to%20be%20working.%20This%20is%20what%20I%20did%20to%20add%20an%20alias.%3C%2FP%3E%3CP%3EI%20logged%20into%20my%20Tenant%20via%20GUI.%20Oen%20Exchange%20Admin%2C%20and%20from%20recipient%20I%20tried%20to%20modify%20the%20email%20properties%20and%20added%20anew%20email%20as%20an%20aliases.%20Wait%20for%2030%20min%20to%2060%20min%20and%20when%20I%20started%20sending%20emails%20to%20that%20mailbox%20on%20the%20alias%2C%20it%20kept%20on%20failing.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAs%20an%20alternate%20I%20went%20to%20O365%20Portal%2C%20in%20Active%20Users%2C%20i%20selected%20the%20same%20mailboxes%20and%20added%20the%20alias%20there.%20After%2010%20min%2015%20min%20I%20was%20able%20to%20send%20the%20email%20to%20the%20same%20mailbox%20with%20a%20newly%20setup%20alias.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20the%20native%20Exchange%20Online%20option%20is%20no%20longer%20valid%20or%20what%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-938389%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Contributor

This question is not about how to add but I've noticed a change and native way of adding a new email alias via Exchange online mailbox properties does not seems to be working. This is what I did to add an alias.

I logged into my Tenant via GUI. Oen Exchange Admin, and from recipient I tried to modify the email properties and added anew email as an aliases. Wait for 30 min to 60 min and when I started sending emails to that mailbox on the alias, it kept on failing. 

 

As an alternate I went to O365 Portal, in Active Users, i selected the same mailboxes and added the alias there. After 10 min 15 min I was able to send the email to the same mailbox with a newly setup alias. 

 

Is the native Exchange Online option is no longer valid or what?