Excel scroll lock stuck on, sheet scrolls, can't use arrows to move between cells

New Contributor

Hi, something weird went wrong with my laptop the other day and the comma button stuck on in every application continuously.  I shutdown the computer  - HP Envy 360 and it seemed fixed but now weird things are happening.  In excel when I used to be able to move between entering data in cells by using arrows, now a round black circle appears under any cell I'm in and I can't enter data by using arrows.  The sheet appears to be locked and scrolls, rather than moving between the cells.  I have no scroll lock button but have tried turning the mouse to be the option on the top menu. Then on the bottom menu I have right clicked and brought up options and tried turning scroll lock on and off that way.  I have tried fiddling in the advanced options with no luck as well.  Could someone please help?  Then Pom

2 Replies
Seems I did all the right things but it needed a "restart" to be effective. Hope that helps someone else with same problem.
WTF microsoft... everytime you update excel the arrow navigation is broken in yet another new and "exciting" way. How about just actually not screwing with the scroll lock state and better still actually follow it.