Email delivery issue using a federated domain (SSO, G Suite as IdP) from within Microsoft apps

New Contributor

Good day.

 

I've successfully managed to setup SSO and provisioning between G Suite (identity provider) and Office 365 using this guide(https://www.goldyarora.com/g-suite-to-office-365-sso/) and everything seems to be working fine except for email when using o365 apps..

 

In my o365 admin panel I have two domains:

 

1) xxx.onmicrosoft.com (default, only for primary admin users,)

 

2) A federated domain zz.org for G Suite users who get auto-provisioned into O365.

 

The federated domain zzz.org (status healthy) in the o365 admin panel doesn't have any DNS records set atm coz I'm using gmail for email delivery

 

The domain zz.org is set to use gmail in the Namecheap control panel ("Advanced DNS\MAIL Settings\Gmail").

 

I want all my zz.org o365 users to use G Suite's gmail for mailing etc from within o365 apps (teams etc) etc.


A bit more on the problem:

 

1)First of all I'm a bit confused about what I should set in "Accepted domains" (Exchange) for my federated domain - internal relay or authoritative https://imgur.com/b92ADHP

 

If I select internal relay I get a warning "There is no outbound connector to deliver mail for this domain. Make sure that there's an Outbound Connector of the type OnPremises that matches every 'internal relay' accepted domain. The connector can either have the AllAcceptedDomains flag enabled or have a recipient domain that matches the accepted domain."

 

2) Second. I haven't set any DNS records in o365 admin panel for my federated domain.

https://imgur.com/a/CqtbOyp

Is this right considering I'll be using gmail?

 

3) When I click on my federated domain and then on "Users"

I get this

https://imgur.com/yvZ6CQP

Is this coz I haven't set DNS Records in 0365 admin panel for this domain(they only offered Exchange mail)

 

Now here is what happens:

 

User1(federated) schedules a teams meeting and adds User2(federated) to participants list.

The event is saved in the calendar. User2 can see it in the calendar,no problem here.

 

However, User2 doesn't receive any invitation email. The only email he receives is when he gets invited to join a teams group (from noreply@email.teams.microsoft.com)

 

When I add a guest to the event I created and then click send, the event window closes and in the calendar windows I see a small circle icon rotating for quite some time until it stops (I guess it means it fails to send email invitations)

 

I'm trying to figure out where the problem is and how to fix it. Most likely I need to change exchange settings..domain type, add connector(?) , I dunno.

 

Kind regards.

2 Replies
Update #2

I've checked Outlook and it looks like I receive all invites to outlook inbox instead of gmail.

How can I change it to gmail??