Content Search and custom sensitive information types

Occasional Contributor

I'm trying to use the Content Search functionality in Security&Compliance portal together with custom sensitive information types, but I get an error (CS999-013) when running the search. 

 

Here's how I can reproduce the error:

 

1. Create a new custom sensitive info type named "Custom Test" (I've tried both by using New-DlpSensitiveInformationTypeRulePackage and by simply creating one from the portal). I've tested in the portal that the info type works.

 

2. Run content search with query: SensitiveType:"Custom Test"

 

Result: 

 

Error:

The search job has failed. Internal server error occurred. Please try again later. If you keep getting this error, contact your admin. (CS999-013)

 

I created the sensitive information type 5 days ago so this shouldn't be any background synchronization issue.  If I use any existing sensitive info types, the search works fine. I use an account that is global admin & compliance admin & eDiscovery admin.

 

Has anyone else seen this behavior?

2 Replies

Contact support, there's hardly anything else you can do here. I just wanted to mention that sensitive types (custom ones included) are still not supported for eDiscovery/Content searches against Exchange Online. But they should work with SPO and so on.

@markus_pitkaranta   Were you able to resolve this issue.  I am seeing the error only when searching son SensitveType, but other searches run fine, all on SPO.