Can't unhide room from GAL

%3CLINGO-SUB%20id%3D%22lingo-sub-2846616%22%20slang%3D%22en-US%22%3ECan't%20unhide%20room%20from%20GAL%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2846616%22%20slang%3D%22en-US%22%3E%3CP%3ETwo%20years%20ago%20we%20ended%20up%20decommissioning%20two%20of%20our%20conference%20rooms%20so%20we%20disabled%20the%20email%20accounts%20and%20hid%20them%20both%20from%20GAL.%20Now%20we've%20rebuilt%20them%20and%20want%20to%20use%20the%20same%20email%20addresses%20so%20I'm%20attempting%20to%20get%20them%20to%20appear%20back%20on%20the%20GAL.%20I%20was%20able%20to%20get%20one%20to%20unhide%20with%20no%20difficulty%20but%20I%20can't%20seem%20to%20get%20the%20second.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe%20have%20a%20hybrid%20environment%20so%20in%20the%20EMC%2C%20the%20check%20box%20for%20%22Hide%20from%20address%20lists%22%20is%26nbsp%3B%3CU%3Enot%3C%2FU%3E%20checked.%20However%2C%20when%20I%20view%20the%20same%20account%20in%20the%20O365%20Exchange%20admin%20portal%20and%20expand%20%22More%20options...%22%20under%20the%20general%20tab%2C%20%22Hide%20from%20address%20lists%22%26nbsp%3B%3CSTRONG%3Eis%20%3C%2FSTRONG%3Echecked.%20I%20cannot%20clear%20the%20check%20as%20it%20gives%20the%20following%20error%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20operation%20on%20mailbox%20%22...%22%20failed%20because%20it's%20out%20of%20the%20current%20user's%20write%20scope.%20The%20action%20'Set-Mailbox'%2C%20'HiddenFromAddressListsEnabled'%2C%20can't%20be%20performed%20on%20the%20object%20'...'%20because%20the%20object%20is%20being%20synchronized%20from%20your%20on-premises%20organization.%20This%20action%20should%20be%20performed%20on%20the%20object%20in%20your%20on-premises%20organization.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20also%20cannot%20do%20it%20via%20PowerShell%20because%20it%20is%20giving%20the%20same%20error.%20Any%20help%20would%20be%20appreciated!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2846616%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOffice%20365%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOn-Premises%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Visitor

Two years ago we ended up decommissioning two of our conference rooms so we disabled the email accounts and hid them both from GAL. Now we've rebuilt them and want to use the same email addresses so I'm attempting to get them to appear back on the GAL. I was able to get one to unhide with no difficulty but I can't seem to get the second. 

 

We have a hybrid environment so in the EMC, the check box for "Hide from address lists" is not checked. However, when I view the same account in the O365 Exchange admin portal and expand "More options..." under the general tab, "Hide from address lists" is checked. I cannot clear the check as it gives the following error:

 

The operation on mailbox "..." failed because it's out of the current user's write scope. The action 'Set-Mailbox', 'HiddenFromAddressListsEnabled', can't be performed on the object '...' because the object is being synchronized from your on-premises organization. This action should be performed on the object in your on-premises organization.

 

I also cannot do it via PowerShell because it is giving the same error. Any help would be appreciated!

1 Reply
Simply try to "reset" the status on-premises, by toggling the checkbox on, then toggle it back off. If that doesn't help, I'd suggest checking for any sync errors the overall state of the objects within the Metaverse: https://docs.microsoft.com/en-us/azure/active-directory/hybrid/tshoot-connect-object-not-syncing#con...