"Locate Me" button not working and/or cannot manually enter in a location

Occasional Contributor

I've come across several locations for when I click on the "Locate Me" button to determine the location, nothing ever returns, it just sits there spinning.  I've done this both under Microsoft Edge and Internet Explorer.  When I use Chrome, and click on the "Locate Me" button, it returns relatively immediately, but obviously I cannot use the Advanced tools, etc.  Is this a known bug?  Any work around?  I was thinking if I could manually enter in a location that would do, but whenever I type in a location, it doesn't seem to accept it.

5 Replies

@rsun0525 When you click the locate me button your web browser has to ask your permission to share your location. If you don't answer the popup then it will keep spinning. 




@Paul Andrew I've definitely clicked on the button to allow it.  I repeated the test by going to the "newer" https://connectivity.office.com and the "older" https://o365networkonboarding.azurewebsites.net, so going to each site, I got the prompt to allow the location.  As I mentioned previously, if I use Chrome, the location comes up relatively immediately (although it doesn't seem to be correct).  


I was desperate, so I even installed the beta version of the new Edge, same result (I was thinking that since it's more like Chrome, and Chrome "worked" for this, maybe it was some other bug I discovered.


I also thought there was a way to manually enter in a location in that field, is this not the case?


@rsun0525 Yes, you can type in a location. As you are typing a list of matches from Bing is displayed and you can select one of those with your pointer. Here is what it looks like after I type "rome". This avoids the Web Browser location request.


We don't yet support the new Edge web browser for the client.




Yes, this is a puzzle to me, as when I begin typing into that field, I don't see the same thing as you where a list of locations show up.  I don't understand what I need to do differently to get it to work.  I've run this many times on virtual machines all through the world, but found just a few of the machines, I can't do anything with the location (and therefore can't run the advanced tests)


@Paul Andrew   It's interesting.  For the PC's that are working (where I can hit the button and the location comes up), I can type directly in the location field and a list of choices appear, but for the locations where the button does not work, no list of choices appear when I type in a location.  I'm thinking it has to be some sort of bug I've discovered.  Is there anyway I can "bypass" this field and just manual type in something without it doing a look up?