What is suitable naming conventions in code?

Occasional Visitor

Recently, our team discussed how to unify code specifications , we got a conflict of naming conventions

  1. General Naming Conventions 
  2. C# Coding Conventions 

First says:

"DO NOT use underscores, hyphens, or any other nonalphanumeric characters."

"DO NOT use Hungarian notation."

Second says:

"Use camel casing ("camelCasing") when naming private or internal fields, and prefix them with _."

"When working with static fields that are private or internal, use the s_ prefix and for thread static use t_."

We are using C# at work, seems like the second one fits because of it is in "Learn/.NET/C# guide/Fundamentals". I have work with C# for  many years, is '_' and "s_" type is camelCasing? Is it appropriate here?

Our member told me it is .net community standards. So i trace down history here . Is there any other discussion about these rules?

So I want to ask which is suitable , Do we need to use '_' types to fields ?

And I known second type is used by Microsoft to develop samples and documentation, so isn't that misleading in "Learn/.NET/C# guide/Fundamentals"?

 

0 Replies