Unable to launch Microsoft MSIX Package Tool if disconnected from the internet


There are scenarios where the packager VM does not have access to the internet.  Last week we discovered that this interferes with the ability to launch the Msix Packaging Tool app.


One of our clever students found a work-around, but it is a work-around that one should NEVER do.  The workaround was to have the logged in user take ownership of the WindowsPackages folder.  I am a bit baffled why that worked, but it is not something we should be doing.

4 Replies
best response confirmed by John Vintzel (Microsoft)

@TIMOTHY MANGAN How are you installing the app?  The symptom mentioned is generally caused by not installing a license with the app.  If you download the offline copy from the Microsoft Store for Business the free license can be acquired there as well.



@John Vintzel  I think this outlines the process used; you might be right.


1) The MPT app was added to the WIndows Store for Business, and the bundle file downloaded with the license. 

2) I had wanted to use Add-AppXProvisionedPackage on the image, but had problems getting that to work.  So instead dism was used:    dism /Online /Add-ProvisionedAppxPackage /PackagePath:"Microsoft.MsixPackagingTool_2019.402.1632.0_neutral_~_8wekyb3d8bbwe.AppxBundle" /SkipLicense" .

3) dism is run again to install the MPT driver.

4) The image was sysprepped.

5) A clone copy of the image was started and the user logged in. While connected to the internet, the user launched the MPT to the GUI and closed it.

6) The system was shutdown and shapshot taken.

7) The system was booted from the snapshot without connection to the internet.

8) The same userid logs in and attempts to launch the tool.


The same system with internet attached works fine, which doesn't make a ton of sense since the MFA account is not used after Step #1 above. But if the license is needed it is needed.  You can always help everyone out on the correct syntax for either the PS or DSIM commands!




@TIMOTHY MANGAN Sounds like it is a license issue.  Since it is a free app we get a license without any Microsoft account required, which is why it worked with internet connectivity.


We can add some more text to the docs to help mitigate and clarify this issue.



@John Vintzel Yeah, we could use that. I'm finding I need to piece together bits and pieces that don't quite line up.


This article: shows how to get the license file, but the filetype it shows for ConfigMan use is ".bin". 


Meanwhile, this article: shows that the value for LicensePath is an XML file.


It looks to me the the unencoded form of the license file is xml.  And attempts to use the bin file on the dism command with /LicensePath fails with error:

Error: 0x803d0000
The input data was not in the expected format or did not have the expected value.


Using the xml file instead does succeed. I'm ok using the xml file as this is part of image processing so I'm not woried about possible snooping eyes.  But a single document covering how to deploy the tool, including the offline license scenario,  would be great for customers..