SOLVED

MSIX Virtual Container Opening Issue with command "Invoke-CommandInDesktopPackage -PackageFamilyName

Contributor

Hi All,

Any Idea why I am not able to open the virtual cmd.exe/regedit.exe/notepad.exe with below command line.

Invoke-CommandInDesktopPackage -PackageFamilyName WS-FTP-Professional_cd0wgck2zs9pm -AppId WS-FTP-Professional -Command "cmd.exe" -PreventBreakaway
Invoke-CommandInDesktopPackage : System.ArgumentException occurred when attempting to invoke the provided command in desktop package. Run
Invoke-CommandInDesktopPackage -? for usage details. Additional detail: Value does not fall within the expected range.At line:1 char:1
+ Invoke-CommandInDesktopPackage -PackageFamilyName WS-FTP-Professional ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~+ CategoryInfo : NotSpecified: (:) [Invoke-CommandInDesktopPackage], ArgumentException
+ FullyQualifiedErrorId : System.ArgumentException,Microsoft.Windows.Appx.PackageCommands.InvokeCommandInDesktopPackage

2 Replies
best response confirmed by Siva116 (Contributor)
Solution

Hi @Siva116 

 

Have you tried passing the full path to cmd.exe as a parameter? 

 

If you still cannot get it running maybe you want to download Hover, it is small free tool we built.  It provides a GUI wrapper over the same PS commandlet, which allows you to easily launch an EXE inside the container of your desired application.

 

Bogdan

Thanks a lot I have provided full path of cmd.exe/notepad.exe/regedit.exe..... all worked, now able to open virtual things, but not sure why even it was not opened by MSIXcommander.exe tool.. I tried with it and Hover.. I will try it.