MSIX Packaging Tool download not working

Copper Contributor

Help, I cannot download the MSIX Packaging Tool.

From windows 10 PC, when I open Microsoft Store, and select MSIX Packaging Tool:

Click on Get button, this error dialog opens (scroll down):


I click Close button, then this sign in dialog opens:


I click Sign in button, the let's get you signed in dialog opens;

It displays my microsoft account, and I click Continue button,

This error dialog opens:


Is there another way to download this tool?

4 Replies



We do offer an offline download through the store for business web portal. For today though, I would recommend checking out our latest blog post, about our April 2020 release. You can download the tool through that blog post, and if you have never downloaded the tool before, don't forget to grab the license from that post as well. 




Program Manager, MSIX 



I downloaded the tool from the blog post along with the license file.

I tried to install the tool, and the Install MSIX Packaging Tool dialog opens.

When I click install button, the dialog disappears, and it appears that nothing happened.

I checked the WindowsApp folder but got an error message: "you don't have permission to access this folder".

Any suggestions?

@maxwell-em you can use PowerShell to check that the tool was installed (and install it if it isn't there)


I would use get-apppackage to check if it is installed, then use add-apppackage to install it if it isn't (don't forget the license if this is your first time installing the package. 


Alternatively, you can also use our Quick Create VM which has the April release of the packaging tool pre-installed for an easy setup!


I solved the problem. I had disabled some unused services, and a couple of these were related to using windows store and installing store apps. After I enabled these services, I could install MSIX Packaging Tool.

I think these services should be listed as part of the requirements for this tool.

Thanks for your help.